03 towing troubles - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 03-15-2010, 09:17 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
03 towing troubles

I have a 03 6.0 with a banks 6 gun and intercooler. When I tow my boat or drive for a long distance the turbo sounds like it shuts down after I stop the truck. It also loses power under a heavy tow or in hot temps. Living in Florida I get plenty of hot days. Sometimes I hear some type of a blow back sound if I am towing also. I hate to sell it since it is paid for but I can not tow any long distances.
joeinportorange is offline  
post #2 of 5 Old 03-15-2010, 09:21 PM
Super Moderator


 
SuperCrutyPS's Avatar
 
Join Date: Jul 2008
Location: Orangevale, CA
Posts: 14,903
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 203 Post(s)
Thanks: 74
Thanked 444 Times in 428 Posts
Garage
Feedback Score: 0 reviews
Do you have gauges to monitor EGT (Exhaust Gas Temps)?

Are you towing on the tow tune or something higher?


Owner | Operator: Darryl
My Truck: Ol' Guy Garage
Tow Toy: Pilgrim International 31RE3SLF5
United States Navy - IC2 - '76-'80
SuperCrutyPS is offline  
post #3 of 5 Old 03-15-2010, 09:24 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
towing in tow tune. I do have gauges and the egts never exceed anything high. The check engine light comes on and it sometimes gives me an exhaust or turbo code.
joeinportorange is offline  
post #4 of 5 Old 03-15-2010, 09:35 PM
Now I'm Strokin6.4Liters
 
Strokin6Liters's Avatar
 
Join Date: Mar 2008
Location: Johnson City, TN
Posts: 2,446
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 8 reviews
Are you losing any coolant?

2015 CCLB F350 Dually King Ranch - SCT, Flo-Pro, No Limit Fabrication, Recon, Atomic LED

2008 CCSB F250 FX4 6 Speed - Spartan, KEM, S&B, Diamond Eye, Southbend, Top Gun Customz, Javelina, Ranch Hand, Bilstein, Toyo, XD, N-Fab, DDM, Southernlite LED, Weathertech, Recon, Kenwood, JL Audio, Flip Hitch - SOLD

2005 ECSB F250 - SCT, MBRP, ARP, FCDP, S&B, Autometer, Swamp's, Recon, JL Audio, MTX, Bushwacker, Westin, XD, Toyo - SOLD
Strokin6Liters is offline  
post #5 of 5 Old 04-05-2011, 04:54 PM
Powerstroke.org Rookie
 
Join Date: Feb 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Black Smoke

I'm new to the forum. I bought an 03 6.0L and I hauled my 30 Ft camper today for the first time and noticed black smoke and some loss of coolant. The black smoke wasn't continuous and I thought I heard a weird noise coming from under the hood. My first thought was the Turbo but I'm no mechanic and no engine light. Any thoughts would be appreciated.
Scott19725 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome