03 towing troubles - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-15-2010, 09:17 PM
Powerstroke.org Rookie
 

Join Date: Mar 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
03 towing troubles

I have a 03 6.0 with a banks 6 gun and intercooler. When I tow my boat or drive for a long distance the turbo sounds like it shuts down after I stop the truck. It also loses power under a heavy tow or in hot temps. Living in Florida I get plenty of hot days. Sometimes I hear some type of a blow back sound if I am towing also. I hate to sell it since it is paid for but I can not tow any long distances.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-15-2010, 09:21 PM
Super Moderator

 

Join Date: Jul 2008
Location: Orangevale, CA
Posts: 11,525
Thanks: 11
Thanked 100 Times in 94 Posts
Feedback Score: 0 reviews
Do you have gauges to monitor EGT (Exhaust Gas Temps)?

Are you towing on the tow tune or something higher?
Reply With Quote Quick reply to this message
  #3  
Old 03-15-2010, 09:24 PM
Powerstroke.org Rookie
 

Join Date: Mar 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
towing in tow tune. I do have gauges and the egts never exceed anything high. The check engine light comes on and it sometimes gives me an exhaust or turbo code.
Reply With Quote Quick reply to this message
  #4  
Old 03-15-2010, 09:35 PM
Now I'm Strokin6.4Liters
 

Join Date: Mar 2008
Location: Johnson City, TN
Posts: 2,431
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 8 reviews
Are you losing any coolant?
Reply With Quote Quick reply to this message
  #5  
Old 04-05-2011, 04:54 PM
Powerstroke.org Rookie
 

Join Date: Feb 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Black Smoke

I'm new to the forum. I bought an 03 6.0L and I hauled my 30 Ft camper today for the first time and noticed black smoke and some loss of coolant. The black smoke wasn't continuous and I thought I heard a weird noise coming from under the hood. My first thought was the Turbo but I'm no mechanic and no engine light. Any thoughts would be appreciated.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:41 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors