Battery Light?? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 03-13-2010, 10:24 AM Thread Starter
Member
 
Strokinallday's Avatar
 
Join Date: Sep 2009
Location: Leesburg
Posts: 31
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Question Battery Light??

I have a 07 psd and my batt light keeps coming on when im going down the road. Not so much while im barely pressing the throttle but when i get into it any at all it comes on and stays on. My attitude monitor says im getting 13.2 volts even when the light is coming on... Any ideas? Maybe a worn out belt or possibly I need a new alternator.
Strokinallday is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 03-13-2010, 02:50 PM Thread Starter
Member
 
Strokinallday's Avatar
 
Join Date: Sep 2009
Location: Leesburg
Posts: 31
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Pleeeease help me out on this....
Strokinallday is offline  
post #3 of 5 Old 03-13-2010, 07:20 PM
Banned
 
Join Date: Jan 2010
Location: Southeast Michigan
Posts: 779
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: -1 reviews
more than likely a bad alt, have it tested
fordmasterdieseltech is offline  
post #4 of 5 Old 03-14-2010, 04:52 PM
Powerstroke.org Fanatic
 
Join Date: Mar 2010
Posts: 144
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
You should be getting like 13.5v or more at idle, If you haven't had your alternator checked do that first. Unless your belt is slipping or fell off then it's not going to be a belt. I had an issue with my truck where the positive battery cable from alternator to battery had a bad connection and wouldn't charge. check Voltage at alternator, positive lead to positive terminal, grnd terminal to case check voltage, then check and see if its about equal on the battery.
russf is offline  
post #5 of 5 Old 07-22-2010, 08:12 PM
Premium Member
 
jensenrcng's Avatar
 
Join Date: May 2008
Location: surprise, az
Posts: 436
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
did you ever figure this out cause my truck is now doing the same thing.
jensenrcng is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome