Glow **** 4 gauge pod, help - Ford Powerstroke Diesel Forum
6.0L Powerstroke Interior Discussion This Section is for interior discussion

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-24-2012, 05:31 AM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Location: Portsmonth,VA
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Glow **** 4 gauge pod, help

Ok So my Boss has a 04 harley edtion f350. He bought the 4guage pod kit from glow shift. When trying to install it the bottem pod hits the dash. Anyone else have this problem? If so what did you do to slove it?
Thanks alot guys!
James

HAHA sorry for the misspelled title...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-25-2012, 02:08 PM
Compression Ignition Addict
 

Join Date: May 2011
Location: East Tennessee
Posts: 693
Thanks: 0
Thanked 10 Times in 4 Posts
Feedback Score: 9 reviews
I bought a ProPods gauge pod!
Reply With Quote Quick reply to this message
  #3  
Old 07-26-2012, 12:01 AM
Banned
 

Join Date: Oct 2011
Location: Carrollton Ohio
Posts: 8,839
Thanks: 65
Thanked 55 Times in 37 Posts
Feedback Score: 10 reviews
mine touches it but it doesn't force it out of place or anything. your supposed to mount the pod on the a pillar first and screw it in place then take it off get your gauges installed in the pod cut a hole in the pillar for the wiring to come out the bottom then install on the a pillar. I did mine and it worked fine. watch the install videos on their website if you are having anymore problems with it.
Reply With Quote Quick reply to this message
  #4  
Old 07-26-2012, 12:18 AM
Premium Member
 

Join Date: May 2011
Location: Lafayette, Indiana
Posts: 588
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by JACT View Post
Ok So my Boss has a 04 harley edtion f350. He bought the 4guage pod kit from glow shift. When trying to install it the bottem pod hits the dash. Anyone else have this problem? If so what did you do to slove it?
Thanks alot guys!
James

HAHA sorry for the misspelled title...
My bottom pod hits the dash on my 99, so the top of the pillar isn't fully seated with the top of the factory pillar. I might switch pillars, but I don't know if I want to drop $50-60 on another pillar pod.
Reply With Quote Quick reply to this message
  #5  
Old 07-26-2012, 03:19 PM
Powerstroke.org Rookie
 

Join Date: Jun 2012
Location: Portsmonth,VA
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yeah, he finely got in today. It just touchs on the bottem now.. Thanks guys!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:43 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors