Lariat power windows quit working - Ford Powerstroke Diesel Forum
6.0L Powerstroke Interior Discussion This Section is for interior discussion

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-16-2012, 07:07 PM
Member
 

Join Date: Nov 2009
Location: Church Hill, TN
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Lariat power windows quit working

First off, this is a 2005 F350 Lariat Crew Cab.

Last night, the power windows worked fine. Got in the truck tonight, and all five windows (four doors & sliding rear) are non-functional. Checked the switches on all doors (and the dash switch for the rear window), none do anything. Everything else (radio, interior lights, cluster, etc.) are working normally.

Pulled the circuit breaker, stuck a 30a fuse in just to check, still nothing. When ignition is on, I have no power in the socket for the circuit breaker. Per my Haynes manual, the power for the windows uses a light blue wire with a black stripe - I found two of these entering the rear of the fuse box, neither have power (ignition on). I would have checked the power source for the blue/black wire, but I'm not sure where it originates.

I removed a malfunctioning Viper alarm last night, but the windows (driver's, at least) were working after that.

Anyone have any ideas as to what I should check next?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-17-2012, 12:43 PM
Member
 

Join Date: Nov 2009
Location: Church Hill, TN
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I've done some further checking today, and I have power to the Delayed Accessory relay - I can jumper from that power to the output terminal the circuit breaker plugs into, and the windows will work. So it seems the power is not being transferred for some reason from the relay to the circuit breaker. I have swapped the relay for another, with no improvement.

Also, I noticed that my opera lights (front and rear) are not working, but I'm not certain if this is related.

I checked with a friend who is a Super Duty tech at a local Ford dealership, he said that he's seen the circuit boards in the fuse box itself go bad. Anyone else heard of this before?
Reply With Quote Quick reply to this message
  #3  
Old 07-17-2012, 05:58 PM
Member
 

Join Date: Nov 2009
Location: Church Hill, TN
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Did some more digging in the fuse box/wiring, found the fuse box is fine, but I'm not getting power to the control circuit for the relay. Not sure which wire (solid light blue & green w/yellow) is power and which is ground, neither have power with ignition on.
I guess at this point I'm probably going to need a wiring diagram for the dash/ignition switch if someone may have one, or if someone can tell me which of the two wires is power, and where it gets that power?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:47 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors