Heated seats aren't heating - Ford Powerstroke Diesel Forum
6.0L Powerstroke Interior Discussion This Section is for interior discussion

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 05-31-2012, 12:00 PM Thread Starter
powercat's Avatar
Join Date: May 2012
Location: Shawnee KS
Posts: 79
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Heated seats aren't heating

I just purchased an 05 X limited and the seats don't seem to be heating
the light on the side of the seat lights up but no heat. Since the light is coming on i'm thinking the fuse is ok or is that on another circut? Hows the best way to chase this down
powercat is offline  
Sponsored Links
post #2 of 2 Old 06-03-2012, 09:45 PM
Compression Ignition Addict
Join Date: Dec 2011
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
most likely one of the heating pads is bad. you have to check resistance through each to see which is open. the seat will have to be disassembled to replace the heating element
mint-6oh is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome