heater fan stuck on full bore - Ford Powerstroke Diesel Forum
6.0L Powerstroke Interior Discussion This Section is for interior discussion

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-12-2012, 05:55 PM
Powerstroke.org Fanatic
 

Join Date: Jun 2007
Location: aberdeen, WA
Posts: 132
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
heater fan stuck on full bore

Even with the climate control module off the fan runs wide open. It started today driving down the road. the fan sped up to the same speed as when it was on 4 bars. I turn it up all the way and it speeds up. I turn it down and it slows down to the fourth bar speed, even though it only shows 1. Then it got stuck on full blast. soooo, as long as the key is on, the fans on full defrost. Obviously, I would like to fix this issue right away. I unplugged the fan motor for now. If anyone has any idea what might be going on, please share
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-15-2012, 07:30 PM
Glow Plugs Only
 

Join Date: Mar 2011
Location: Ontario, Canada
Posts: 1,442
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It's most likely the fan resister. I don't know where it is on these trucks but it went on my Liberty and my Jetta and I only had high until I replaced them. It's designed so you still have a defrost but only high speed if it goes. Hopefully one of the Techs will chime in soon.
Reply With Quote Quick reply to this message
  #3  
Old 02-19-2012, 09:45 AM
Powerstroke.org Fanatic
 

Join Date: Jun 2007
Location: aberdeen, WA
Posts: 132
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I did some research and found that quite a few people had this issue. Everyone was saying the blower speed control module is the cause. I ordered one and I'm picking it up soon. I will report back when I find out if it worked or not.
Reply With Quote Quick reply to this message
  #4  
Old 02-19-2012, 01:20 PM
Powerstroke.org Fanatic
 

Join Date: Jun 2007
Location: aberdeen, WA
Posts: 132
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
They really messed up. I sent my dad in to pick it up for me since I was out of town Saturday. They gave me a MAF sensor. F6dz-12b579-arm. Not even remotely close to what I need! Looks like the wait continues.
Reply With Quote Quick reply to this message
  #5  
Old 02-21-2012, 10:08 PM
Powerstroke.org Fanatic
 

Join Date: Jun 2007
Location: aberdeen, WA
Posts: 132
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Blower speed control module it is! All fixed.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:52 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors