Why in the HELL aren't these heated seats working??? - Ford Powerstroke Diesel Forum
6.0L Powerstroke Interior Discussion This Section is for interior discussion

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 09-18-2011, 06:09 PM Thread Starter
Compression Ignition Addict
onewheelneil's Avatar
Join Date: Apr 2009
Location: Durham, NC
Posts: 398
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Why in the HELL aren't these heated seats working???

I have searched the forum and google for that matter and can't seem to come up with a solution to get these things working......I checked the underdash fuse and it seemed fine.Every other button and switch in the whole truck works except for either driver or passenger heated seats.Press the button and no light on either seat.What else can I check?

Hear the whistle, see the smoke, your *** just got passed by a POWERSTROKE!!!
onewheelneil is offline  
Sponsored Links
post #2 of 2 Old 09-19-2011, 05:02 AM
Compression Ignition Addict
Davey~do's Avatar
Join Date: Nov 2008
Location: Lumberton, TX
Posts: 855
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 1 Post
Feedback Score: 0 reviews
Davey~do is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome