SCT Help - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 06-19-2009, 05:10 PM Thread Starter
Compression Ignition Addict
 
extremlx's Avatar
 
Join Date: Feb 2009
Location: Virginia
Posts: 430
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to extremlx
SCT Help

You guys know I bought the SCT I have from ID Xstreet tune I did a full egr delete on the truck over the weekend and just for piece of mind I put the truck back to stock. Did the mod and went for a ride the truck felt great a little more peppy and I was thinking that with the tuner It really ought to shine. But when I put the tune back on the truck feels dead compared to no tune at all what gives the egts went up to way up as well but not any more power? and thats the way it was before I did the EGR delete. I drove it with the stock set up for a couple of days before the mod and it felt like a beast. it like the only thing the tuner is doing is making it smoke and get hot but not really going any where.HHHHEEEELLLPP!!

---LEE---
ARP studs, BPD oil cooler and water pump, CFM+, Volant Cold Air, MBRP Stainless Duals, SCT X3 from TSD,IDP & CTS, Kenwood 8120 & rear camera, 18" Helio Maxx 8 on 37" Grapplers, 6" Skyjacker Lift, OUO Traction Blocks and Bars, AutoMeter Tran. temp, Boost, EGT, above mirror pod & 4.30 gears, ARB rear locker, Coolant returns, RR kit, CCV mod, Harpoon mod

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
extremlx is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 06-19-2009, 05:40 PM
Banned
 
Join Date: Dec 2008
Posts: 2,850
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Heres a bump for you, I have no clue
03-blue-Powerstroke is offline  
post #3 of 11 Old 06-19-2009, 05:44 PM
Compression Ignition Addict
 
DunesRunner08's Avatar
 
Join Date: Mar 2008
Location: Ft Lauderdale, FL
Posts: 5,838
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
wow... im stumped... i'll give you another bump though

Beware!!!! The King Has Returned

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
DunesRunner08 is offline  
post #4 of 11 Old 06-19-2009, 08:11 PM
Ihre Mama mag mich


 
Ozone-etr1's Avatar
 
Join Date: Jan 2009
Location: im Doppelpunkt nach links
Posts: 550
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
im thinking you bumped some censor loose in stock mode it might default to standard parameters.....but i would think when you use a tune it pushes the "window" on the reading it recieves causing a fault and no power....
1) did you get a CEL
2) look if you pinched or disconected an injector wire while you were there
3)if you didnt do a compleet deleet than crack the cap on the overflow tank and see if you have greater constant pressure maby the EGR cooler cracked on the intake side of it now you have a boost leak
4)go back to stock then upload agin..
thats all i can think of
Ozone-etr1 is offline  
post #5 of 11 Old 06-19-2009, 08:13 PM
Ihre Mama mag mich


 
Ozone-etr1's Avatar
 
Join Date: Jan 2009
Location: im Doppelpunkt nach links
Posts: 550
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
oh look at the VGT see if that thing is pluged in could have poped out
Ozone-etr1 is offline  
post #6 of 11 Old 06-24-2009, 05:13 PM Thread Starter
Compression Ignition Addict
 
extremlx's Avatar
 
Join Date: Feb 2009
Location: Virginia
Posts: 430
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to extremlx
well guys still no luck, looked for any thing that might be unplugged and nothing returned the truck back to stock and drove fine it would shift out of fifth with just a slight roll on to the pedal and then put the Xtreme street back in and the roll on in fifth had to be matted to get it to down shift up until then black smoke rolling from loading up starting to worry!!!

---LEE---
ARP studs, BPD oil cooler and water pump, CFM+, Volant Cold Air, MBRP Stainless Duals, SCT X3 from TSD,IDP & CTS, Kenwood 8120 & rear camera, 18" Helio Maxx 8 on 37" Grapplers, 6" Skyjacker Lift, OUO Traction Blocks and Bars, AutoMeter Tran. temp, Boost, EGT, above mirror pod & 4.30 gears, ARB rear locker, Coolant returns, RR kit, CCV mod, Harpoon mod

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
extremlx is offline  
post #7 of 11 Old 06-24-2009, 07:21 PM
Ihre Mama mag mich


 
Ozone-etr1's Avatar
 
Join Date: Jan 2009
Location: im Doppelpunkt nach links
Posts: 550
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
but other than the down shift in fifth does it run ok?
Ozone-etr1 is offline  
post #8 of 11 Old 06-24-2009, 07:38 PM
Ihre Mama mag mich


 
Ozone-etr1's Avatar
 
Join Date: Jan 2009
Location: im Doppelpunkt nach links
Posts: 550
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
hey exteem PM me
Ozone-etr1 is offline  
post #9 of 11 Old 06-25-2009, 07:00 PM Thread Starter
Compression Ignition Addict
 
extremlx's Avatar
 
Join Date: Feb 2009
Location: Virginia
Posts: 430
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to extremlx
we think we have it locked down to a sticking turbo the stock V-vein gonna take it off and clean it ! keep ya posted

---LEE---
ARP studs, BPD oil cooler and water pump, CFM+, Volant Cold Air, MBRP Stainless Duals, SCT X3 from TSD,IDP & CTS, Kenwood 8120 & rear camera, 18" Helio Maxx 8 on 37" Grapplers, 6" Skyjacker Lift, OUO Traction Blocks and Bars, AutoMeter Tran. temp, Boost, EGT, above mirror pod & 4.30 gears, ARB rear locker, Coolant returns, RR kit, CCV mod, Harpoon mod

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
extremlx is offline  
post #10 of 11 Old 06-27-2009, 08:18 AM Thread Starter
Compression Ignition Addict
 
extremlx's Avatar
 
Join Date: Feb 2009
Location: Virginia
Posts: 430
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to extremlx
I poured a quart of atf in the tank and it lubed the viens in the turbo and all is well now!!

---LEE---
ARP studs, BPD oil cooler and water pump, CFM+, Volant Cold Air, MBRP Stainless Duals, SCT X3 from TSD,IDP & CTS, Kenwood 8120 & rear camera, 18" Helio Maxx 8 on 37" Grapplers, 6" Skyjacker Lift, OUO Traction Blocks and Bars, AutoMeter Tran. temp, Boost, EGT, above mirror pod & 4.30 gears, ARB rear locker, Coolant returns, RR kit, CCV mod, Harpoon mod

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
extremlx is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome