Banks 6 six gun with PDA issues - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-29-2009, 05:16 AM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Location: Zionsville
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Powerstroke Epic Send a message via Skype™ to Powerstroke Epic
Banks 6 six gun with PDA issues

My 05 F250 went in recently to have the FICM (fuel injection control module) replaced. The banks work perfected before I took it in. When I got it back the technician had unhooked the ECU jumper and ODBII connection. The technician is a friend and warned me that he would have to unhook my programmer to do the work. He also flashed the truck with the updated software with warning that my programmer might not work. When i got it home I hooked up the banks and immediately the turbo didn't work and it threw 5 codes. I called banks tech support and they had me reset the programmer with there reset process. I then started the truck again and found the turbo to be back but still throwing 3 codes. I take the truck on a test drive to then lose the turbo again and still throwing 3 codes. The only thing I haven't tried is deleting the software of the PDA and reloading it. Banks has no idea what the problem is, a local banks dealer has never heard of it either. Has any one had this problem?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-29-2009, 10:37 AM
Compression Ignition Addict
 

Join Date: Jan 2009
Location: s. arlington, tx
Posts: 1,538
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Lubbockguy1979
Sounds like it might be time to upgrade to a better tuner that more of the 6.0 crowd are familiar with...
Reply With Quote Quick reply to this message
  #3  
Old 04-29-2009, 11:48 AM
Illiana Chapter Director

 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 11,923
Thanks: 4
Thanked 47 Times in 44 Posts
Feedback Score: 2 reviews
Quote:
Originally Posted by Powerstroke Epic View Post
My 05 F250 went in recently to have the FICM (fuel injection control module) replaced. The banks work perfected before I took it in. When I got it back the technician had unhooked the ECU jumper and ODBII connection. The technician is a friend and warned me that he would have to unhook my programmer to do the work. He also flashed the truck with the updated software with warning that my programmer might not work. When i got it home I hooked up the banks and immediately the turbo didn't work and it threw 5 codes. I called banks tech support and they had me reset the programmer with there reset process. I then started the truck again and found the turbo to be back but still throwing 3 codes. I take the truck on a test drive to then lose the turbo again and still throwing 3 codes. The only thing I haven't tried is deleting the software of the PDA and reloading it. Banks has no idea what the problem is, a local banks dealer has never heard of it either. Has any one had this problem?
What codes are you getting? Have you tried updating the PDA yet?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:22 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors