HELP gauges wont light up - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-25-2009, 09:15 PM
Powerstroke.org Rookie
 

Join Date: Oct 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HELP gauges wont light up

i installed a pyro tranny and boost optix a pillar gauges in my truck. they all work fine except i cant get them to light up. i've got it wired into the dimmer which has power to it, all the knob dimmers in the back of the individual gauges have been messed with and theres no problem with where my ground is. is there something else i'm missing here or should i just wire it straight to the battery.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-25-2009, 09:17 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Moose jaw,saskachewan,canada
Posts: 2,022
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
do you have them both grounded to the same spot?
Reply With Quote Quick reply to this message
  #3  
Old 04-25-2009, 09:18 PM
Shaking the Bush Boss
 

Join Date: Feb 2007
Location: Salisbury, NC
Posts: 9,740
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
seperate the lights ground.
Reply With Quote Quick reply to this message
  #4  
Old 04-25-2009, 09:23 PM
Rob Rob is offline
Super Moderator


 

Join Date: Aug 2006
Location: Layton, Utah
Posts: 13,239
Thanks: 3
Thanked 7 Times in 4 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rob Send a message via MSN to Rob Send a message via Skype™ to Rob
you can ground it all to one spot... i have mine that way, and they work. what other wires did you hook up to? what color wire did you splice into on the dimmer?
Reply With Quote Quick reply to this message
  #5  
Old 04-26-2009, 05:55 PM
Compression Ignition Addict
 

Join Date: Jan 2009
Location: s. arlington, tx
Posts: 1,547
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Lubbockguy1979
Had that issue last night make sure that all your connections are good. The boost is mechanical and the egt and tranny use 2 power sources one for the boxes and one for lights. Double check all your ground and power connections
Reply With Quote Quick reply to this message
  #6  
Old 04-26-2009, 06:21 PM
Mod Newbie


 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 12,706
Thanks: 6
Thanked 114 Times in 107 Posts
Feedback Score: 2 reviews
I just hooked those kind of gauges up in my truck last week. If you go buy the directions that are sent with the gauges then you have 2 gauges that will only light up when the key is on. I wired it like this. The grey and black wires out of each gauge I hooked together and then daisy chained them with a common ground wire and grounded under the dash. The red wire out of each gauge, I daisy chained a common wire and tapped into a switched 12v source under the dash. The white wire from each gauge, I daisy chained a common wire and tapped into the dimmer wire at the headlight switch. If you go by there directions, then the trans. temp. and the boost gauge light up when your key is on. Hope this helps some.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:37 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors