My TURBO is bad. - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 03-26-2009, 04:28 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2009
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My TURBO is bad.

I just found out today when the dealer pulled codes, that my Turbo and VGT are bad. I have never changed one before but I'm willing to give it a shot. Does anyone know if I should try to find one on here and replace mine with it or rebuild mine, and whichever way I go is there anything I need to buy when I put the next one in? My truck is a 03 F250 all stock, 113k.
roadking624 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 03-26-2009, 04:35 PM
Powerstroke.org Fanatic
 
Join Date: Jan 2009
Posts: 138
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
dont know what to tell on wether rebuilding yours or getting a new one but i did take the turbo off my 03 6.0. Its not near as bad as it looks, the hardest bolt to get to is the back bolt on the mounting bracket on the turbo. The other ones arnt extremly easy but its not bad. Goodluck

2003 f 250 ext cab 6.0 6 speed 5" turbo back straight piped K&N cold air intake SCT with custom tunes from innovative diesel pyro,boost,trans temp gauges
03_stroker is offline  
post #3 of 7 Old 03-26-2009, 08:01 PM
Compression Ignition Addict
 
!!!PainTrain!!!'s Avatar
 
Join Date: Jan 2008
Location: Williamsport, MD
Posts: 2,229
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
What exactly is wrong with it? From doing nothing but pulling codes I would think they are only reading a bad sensor. You would know from driving it if the turbo was toast.

Performance: SCT Xcal-Innovative Diesel, 4" Turbo Back Exhaust no muffler and kitty missing, Spearco IC, ID Power Elbow, AFe Stg. II Intake, 03 Turbo.
Exhaust Clip:http://www.youtube.com/watch?v=mYF9HgB0RwY

Looks: Westin Black Powder Coated Bull Bar, Recon Smoked Cab, Mirror Lights, and 3rd Brake Light, 4" Superlift kit, 35" ProComp Extreme A/T's, 18x10 Diamo Black & Chrome Rims.
!!!PainTrain!!! is offline  
post #4 of 7 Old 03-26-2009, 08:04 PM
Compression Ignition Addict
 
!!!PainTrain!!!'s Avatar
 
Join Date: Jan 2008
Location: Williamsport, MD
Posts: 2,229
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Also, here is a link that gives you some info on how to clean your turbo:

Diesel Technician Society

Performance: SCT Xcal-Innovative Diesel, 4" Turbo Back Exhaust no muffler and kitty missing, Spearco IC, ID Power Elbow, AFe Stg. II Intake, 03 Turbo.
Exhaust Clip:http://www.youtube.com/watch?v=mYF9HgB0RwY

Looks: Westin Black Powder Coated Bull Bar, Recon Smoked Cab, Mirror Lights, and 3rd Brake Light, 4" Superlift kit, 35" ProComp Extreme A/T's, 18x10 Diamo Black & Chrome Rims.
!!!PainTrain!!! is offline  
post #5 of 7 Old 03-26-2009, 08:27 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2009
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What's wrong is, when I'm driving down the highway at like 70-75 and accelerate to pass someone, the truck starts bucking and puffing out black smoke everytime it bucks and I get poping through the turbo. Also when I accelerate hard to get on the highway it does the samething. The dealer found codes that says the VGT is bad and inturn messed up the veins in the turbo, they say thery are binding.
roadking624 is offline  
post #6 of 7 Old 03-26-2009, 08:43 PM
Compression Ignition Addict
 
DYNAMiTE's Avatar
 
Join Date: Jan 2009
Location: Forney, TX
Posts: 205
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check your email!

I sent you an email since you cant read PMs! Let me know what you think! -Jim

'07 F250 CC SB
4" Turbo back no cat/muff
S&B Intake
X3 ID Custom Tunes
2" lift 18" Black KMC Monsters w/33" Nitto A/T
Auto-Meter Trans/Boost/Pyro
Zoodad/High Idle mod
HID Head lights and fog lights
AMP Steps
No chrome anywhere!
DYNAMiTE is offline  
post #7 of 7 Old 07-08-2009, 12:39 PM
Powerstroke.org Rookie
 
Join Date: Jul 2009
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have a similar problem. But it only happens when it is cold. What solution did you go with?
bluwolf57 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome