question about the edge attitude - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-05-2009, 05:19 PM
Compression Ignition Addict
 

Join Date: Jan 2009
Location: s. arlington, tx
Posts: 1,538
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Lubbockguy1979
question about the edge attitude

so i got this edge attitude with juice... i hooked it up i am using it for gauges only.... the unit seems to work but does not display rpm or boost. i did not install the pyro yet but it is under the hood and seems to work.... what do i do to get the rpms and the boost to work? and also can i update this thing for more options? my stepdad has his showing mph other stuff i think. the firmware is 4.0 i think any positive help is appreciated.. and btw i am running a xcal2 with spartan tunes. i added the edge and havent unloaded the program (ase) yet
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-05-2009, 05:23 PM
Compression Ignition Addict
 

Join Date: Nov 2005
Location: Far From Bieber
Posts: 2,062
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
On the module under the hood, try reversing the two plugs. I sold mine the other day and put it on the buyer's truck for him. It did the exact same thing and I had to reverse the plugs on the back of the Juice module...worked after that.
Reply With Quote Quick reply to this message
  #3  
Old 03-05-2009, 05:38 PM
Compression Ignition Addict
 

Join Date: Jan 2009
Location: s. arlington, tx
Posts: 1,538
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Lubbockguy1979
awesome will try and repost results ..
Reply With Quote Quick reply to this message
  #4  
Old 03-06-2009, 06:58 AM
Compression Ignition Addict
 

Join Date: Jan 2009
Location: s. arlington, tx
Posts: 1,538
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Lubbockguy1979
Exactly right thanks for the help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:41 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors