p0264 code - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 06-26-2014, 06:51 PM Thread Starter
Compression Ignition Addict
 
strokin6L's Avatar
 
Join Date: Apr 2011
Location: springville NY
Posts: 2,626
Thanks: 24
Thanked 54 Times in 49 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 1 reviews
p0264 code

Well decided to check the IAT sensor today to see if it looked ok and wasn't all carboned up. Pulled it out and looked clean as a whistle. Reinstalled and started the truck up. All of a sudden after start up truck idled really rough and shook pretty bad. Took it for a little drive and still idled rough after I got back. I shut it off and checked ICP connector...that checked out ok. Wiggled the harness where I disconnected the IAT sensor...only because that was the only part of the harness I touched. Started truck back up and still idled rough. Then all of a sudden I got a CEL...p0264 for cylinder #2 injector circuit low. It got late and dark so I didn't look into it any further. I'm thinkin either the injector harness connector at the FICM, injector harness connector at #2 injector or a pinched wire inside the harness. Either way I'm leaning towards something with the injector harness. I have a brand new sitting here that I've had for a spare. What do you guys think?

2004 F-350 SC 4x4, XLT, 4" dual Magnaflow, AFE intake, No Limit piping, spearco intercooler, water injection, ARP studs, hypemax o-ringed heads, SCT tuned by Innovative Diesel, tuned FICM, Hellman's sump, FASS, Fuelab, regulated return, 190/75 injectors, KC/MTW 68 w/.72ar, suncoast trans w/billet input, edge insight CS with dakota digital gauges, amsoil by-pass, BD exhaust manifolds
strokin6L is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 06-26-2014, 10:53 PM
Premium Member
 
snafu!'s Avatar
 
Join Date: May 2012
Location: Anchorage
Posts: 1,469
Thanks: 19
Thanked 50 Times in 43 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
I'm dealing with almost the same problem right now except mines cylinder 6. Ohmed the injector and it was out of spec so ordered a new one from Warren and that didn't fix the problem. I have a new injector harness on the way and going to get a known good ficm from Dale. He also said it is sometimes the connector on the harness, if the gold plating is worn or connector is burnt it will cause a problem.

Cameron
2006 F250 Lariat CCSB
Comp Turbo 64/88 compounds
Warren 285/100
ODAWG ported intake
R&R rods, mahle pistons, stage 2 colt cam
Built Trans
Water/Meth
snafu! is offline  
post #3 of 3 Old 06-27-2014, 06:14 AM Thread Starter
Compression Ignition Addict
 
strokin6L's Avatar
 
Join Date: Apr 2011
Location: springville NY
Posts: 2,626
Thanks: 24
Thanked 54 Times in 49 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 1 reviews
Fixed it. It was the injector plug on #2...It was loose. Took the clip off, reconnected and reinstalled the clip and purred like a kitten.

2004 F-350 SC 4x4, XLT, 4" dual Magnaflow, AFE intake, No Limit piping, spearco intercooler, water injection, ARP studs, hypemax o-ringed heads, SCT tuned by Innovative Diesel, tuned FICM, Hellman's sump, FASS, Fuelab, regulated return, 190/75 injectors, KC/MTW 68 w/.72ar, suncoast trans w/billet input, edge insight CS with dakota digital gauges, amsoil by-pass, BD exhaust manifolds
strokin6L is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome