SCT X3 - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-18-2008, 08:59 PM
Compression Ignition Addict
 

Join Date: Sep 2008
Location: Redding, Ca
Posts: 229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
SCT X3

Ok so i got my X3 today and pluged it into my computer thinking that I could just go on line and update the firmware. appairently i didnt follow the online directions, and the unit will not update. I get a error stating "Failed to write bulk data. Device #0". how do i fix this.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-19-2008, 07:46 AM
Super Moderator


 

Join Date: Mar 2008
Location: Abingdon, Md.
Posts: 11,969
Thanks: 3
Thanked 27 Times in 15 Posts
Feedback Score: 3 reviews
Did you load the device drivers for the X3 onto your PC?
Reply With Quote Quick reply to this message
  #3  
Old 11-19-2008, 08:02 AM
Premium Member
 
Join Date: Feb 2008
Location: Everywhere and Nowhere
Posts: 3,339
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 67ModStang Send a message via Yahoo to 67ModStang
You've got to download the software and drivers onto your computer first. Also when plugging in to update firmware you have hold the cancel button down when you plug in. If you are just loading tunes then you dont have to hold any buttons.
Reply With Quote Quick reply to this message
  #4  
Old 11-19-2008, 08:53 PM
Compression Ignition Addict
 

Join Date: Sep 2008
Location: Redding, Ca
Posts: 229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yes driver is downloaded along with the software and firmware. but because i did not do the correct method like the tutorial states ( because i did not know about it when i plugged the programmer) i still get the "Failed to write bulk data. Device #0" error.

any ideas on how to fix
Reply With Quote Quick reply to this message
  #5  
Old 11-19-2008, 09:09 PM
Compression Ignition Addict
 

Join Date: Sep 2008
Location: Redding, Ca
Posts: 229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
NOTE: DO NOT PLUG IN YOUR DEVICE before viewing the tutorial below. The drivers MUST BE INSTALLED manually. Be sure to follow the instructions in the Installing SCT's USB Drivers tutorial when install the Windows drivers for this device. You can view the tutorial by clicking on the link below: CLICK HERE


this is what i did wrong. so how do i install the drivers manually?
Reply With Quote Quick reply to this message
  #6  
Old 11-20-2008, 12:39 PM
Premium Member
 
Join Date: Feb 2008
Location: Everywhere and Nowhere
Posts: 3,339
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 67ModStang Send a message via Yahoo to 67ModStang
Ok, I think I know what you did now. I'm gonna try to walk through this.

First off, you should have downloaded the file LWdrivers.zip from the SCT site.
You need to unzip this file to somewhere that you can locate later on.

Next, since you already plugged in you SCT to the computer, you will need to manually install the driver using the device manager in windows. If you don't know how to open the device manager here are the directions: Right-click on the My Computer icon on your desktop and click on properties. Next you will click on the hardware tab on the window that just opened. Next click on the Device Manager button. Scroll all the way to the bottom of the list that comes up. Click on the plus next to Universal Serial Bus Controllers. This is where the driver utility for the SCT will show up.

Now go ahead and plug your SCT into the computer. A line for SCT USB Driver(SEE A) should show up in the device manager. Double click on it. This will take you to the properties page. Now click on the Drivers tab(SEE B) and then the Update Driver button(SEE C). The Update Harware Wizard should come up. Click on "No, not this time"(SEE D) and then click next.

On the next screen click on "Install from a list or specific location(Advanced)"(SEE E) then click next.

On the next screen uncheck "Search removable media"(SEE F) and check the "Include this location in the search" box(SEE G). Next click the browse button and locate the folder that you unzipped the LWDriver files to earlier. Click OK then Click Next. The program should locate the file and install it from there.


I don't know if my edits are gonna show up in the pics but everything is in the pics how it should be. If there is anything else you need let me know.
Reply With Quote Quick reply to this message
  #7  
Old 11-20-2008, 06:33 PM
Compression Ignition Addict
 

Join Date: Sep 2008
Location: Redding, Ca
Posts: 229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
That was awsome thanks. now i try to download the new software and i get the following error

invalid firmware! Load the correct firmware or contact customer support @ SCT Automotive Performance Products
Reply With Quote Quick reply to this message
  #8  
Old 11-20-2008, 06:45 PM
Premium Member
 
Join Date: Feb 2008
Location: Everywhere and Nowhere
Posts: 3,339
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 67ModStang Send a message via Yahoo to 67ModStang
Ok, there are a couple different firmware versions. Read this and see if it helps:

IMPORTANT NOTICE REGARDING X3 & SF3 Power Flash Devices sold prior to July 25th, 2008:
SCT has recently updated the firmware for all X3 & SF3 devices. These devices now have different firmware that will effect all future updates for your device.

--------------------------------------------------------------------------------

X3 devices part #3000 sold after July 25th, 2008 will now only be used for custom tuning and will no longer contain pre-loaded tunes. The SF3 device part #3015 will hold 3 custom tunes and will ship with pre-loaded tunes as in the past.

--------------------------------------------------------------------------------

If you have purchased an X3 device part #3000 or SF3 device part #3015 prior to July 25th, 2008, your device is now considered an SF3 device part #3015, even though the device stickers may state it is a part #3000. When updating your device with any future firmware or tune revisions, you must use the SF3 part #3015 device updates or you will receive an error when updating the device.

--------------------------------------------------------------------------------

Devices sold after July25th, 2008 should use the matching firmware for the part number on the device sticker.
Reply With Quote Quick reply to this message
  #9  
Old 11-20-2008, 06:52 PM
Premium Member
 
Join Date: Feb 2008
Location: Everywhere and Nowhere
Posts: 3,339
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 67ModStang Send a message via Yahoo to 67ModStang
Basically all I need to know is if you have the 3000 or 3015 and the first 2 digits of the # on the back. I am going to assume that you bought it recently.
Reply With Quote Quick reply to this message
  #10  
Old 11-20-2008, 06:55 PM
Compression Ignition Addict
 

Join Date: Sep 2008
Location: Redding, Ca
Posts: 229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yeah X3 is the first two #s
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:45 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors