tackling the EGT monster- - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Like Tree38Likes
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-13-2014, 06:25 AM
Compression Ignition Addict
 

Join Date: Jun 2012
Location: Trinidad Colorado ,USA
Posts: 5,469
Thanks: 113
Thanked 143 Times in 141 Posts
Feedback Score: 0 reviews
tackling the EGT monster-

Ive been fighting with egt's since Ive had my truck. Put it this way, I can very easily get the Edge to start beeping on the average on ramp, empty not towing.
I have a atlas 40 and that did help. The atlas 80 made the truck run great but egt's were terrible.
So here is my options-
1- get rid of the ficm tune all together and go with a sct tune.
2-For around $1100 I can get a complete Banks intercooler kit. I have done alot of reading and have read good and not so good about this set up.
3-Water methanol (around $900) Going this route does interest me but is this kinda like putting a band aid over a gun shot?

So I guess the smatest/cheapest thing might be to get rid of the Atlas 40 tune. And tune the truck with the sct???

I guess Im just askin for your thoughts on this. Am I missing something? Should I be looking a diffrent direction?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-13-2014, 06:38 AM
Premium Member

 

Join Date: Feb 2012
Posts: 2,463
Thanks: 119
Thanked 190 Times in 134 Posts
Feedback Score: 1 reviews
So you are having problems with cruising and lite accleration egts... Not WOT egts? or is it all of the above?


Have you verified nothing is wrong?
Reply With Quote Quick reply to this message
  #3  
Old 01-13-2014, 06:46 AM
Premium Member
 

Join Date: Aug 2013
Location: 804Va
Posts: 2,685
Thanks: 651
Thanked 117 Times in 97 Posts
Feedback Score: 3 reviews
I was going to ask the same things... also are we sure the probe/sensor are reading correctly?
Reply With Quote Quick reply to this message
  #4  
Old 01-13-2014, 06:57 AM
Premium Member

 

Join Date: Feb 2012
Posts: 2,463
Thanks: 119
Thanked 190 Times in 134 Posts
Feedback Score: 1 reviews
I also forgot to ask... Are you talking about when you are empty or towing?



Here are a couple of things that could cause the issues you describe:

Leaking up pipes
Leaking ypipe to turbo connection
Boost leaks

Check, fix, and clean all sensors, tubes, and connections
IAT
MAF
MAP
EBP
ICP
IPR
VGT
ETC...


A slightly chewed up turbine is hard to notice unless you pull and open up the turbo. I have had a few experimental turbos that had this happen. Everything seemed ok except for pretty high egts. I pulled the turbo and the turbine was chewed up.





Here are a couple of mods that will help:
11 blade single plane billet wheel upgrade
Ported intake manifold (number 1 choice)
Upgraded intercooler
Water injection




I know this may sound werid. But if your max WOT egts are fine and you are just trying to help out your crusing and/or lite acceleration the you could try an 06-07 with a billet wheel. The 06-07 turbo will spool faster and operate much more efficiently at lower rpms and during lite acceleration. (but it will not perform as well up top and will not make as much power)
Reply With Quote Quick reply to this message
  #5  
Old 01-13-2014, 06:59 AM
Compression Ignition Addict
 

Join Date: Jun 2012
Location: Trinidad Colorado ,USA
Posts: 5,469
Thanks: 113
Thanked 143 Times in 141 Posts
Feedback Score: 0 reviews
As far as the probe reading correctly no I cannot guarentee that its reading correctly. I installed it according to the directions I had and the videos I watched. Is their some great way to check the #'s?
The egt's seem to be always a bit hot. I live at 6000' plus in very dry air in the mountains. From what Ive read the thein air and dry air can effect egt's alot so this is why I was looking at water methanol.
Reply With Quote Quick reply to this message
  #6  
Old 01-13-2014, 06:59 AM
Powerstroke.org Fanatic
 

Join Date: Jul 2013
Posts: 111
Thanks: 6
Thanked 11 Times in 11 Posts
Feedback Score: 0 reviews
I just ran into this problem and it turned out to be my gauge. Though they are not cheap pick up a new one and check it out.
Reply With Quote Quick reply to this message
  #7  
Old 01-13-2014, 07:16 AM
Compression Ignition Addict
 

Join Date: Jun 2012
Location: Trinidad Colorado ,USA
Posts: 5,469
Thanks: 113
Thanked 143 Times in 141 Posts
Feedback Score: 0 reviews
This is running empty. Loaded its not good.
Reply With Quote Quick reply to this message
  #8  
Old 01-13-2014, 07:18 AM
Premium Member

 

Join Date: Feb 2012
Posts: 2,463
Thanks: 119
Thanked 190 Times in 134 Posts
Feedback Score: 1 reviews
What are your actually numbers... just for reference

Idle
Cruising at 70mph flat ground
Lite 1/4 throttle 0-70mph
Max WOT egts 0-70mph

Last edited by peixinho; 06-23-2014 at 11:34 AM.
Reply With Quote Quick reply to this message
  #9  
Old 01-13-2014, 07:19 AM
Super Moderator


 

Join Date: Mar 2008
Location: Abingdon, Md.
Posts: 11,971
Thanks: 3
Thanked 29 Times in 15 Posts
Feedback Score: 3 reviews
How about posting some actual numbers and the particulars at the time so we can see what you are talking about.
Reply With Quote Quick reply to this message
  #10  
Old 01-13-2014, 07:20 AM
Compression Ignition Addict
 

Join Date: Jun 2012
Location: Trinidad Colorado ,USA
Posts: 5,469
Thanks: 113
Thanked 143 Times in 141 Posts
Feedback Score: 0 reviews
peixinho-you bring up leaking up pipes,I do find when the truck is just warming up in the morning I have a decent bit of exhaust smell in the cab. Once I start down the road it all goes away.
Thank you for what sensor's to check I guess this could be a good place to start.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:36 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors