is this the right part???? - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-23-2008, 01:26 PM
Compression Ignition Addict
 

Join Date: May 2008
Posts: 178
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
is this the right part????

I just got the Banks high-Ram for my 6.0L with the 03 motor... and I need to know if this is the right part, I am under the impression that there is two versions for the 6.0 motor... anyone that can verify this PLEASE HELP!

here my part


and heres my motor
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-23-2008, 01:30 PM
Premium Member
 

Join Date: Sep 2007
Location: cape may nj
Posts: 2,301
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
take the part # and go onto bankspower.com and match it up. they all look the same from that angle.
Reply With Quote Quick reply to this message
  #3  
Old 08-23-2008, 03:16 PM
Mod Newbie


 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 12,707
Thanks: 6
Thanked 114 Times in 107 Posts
Feedback Score: 2 reviews
Quote:
Originally Posted by Vegas250RR View Post
I just got the Banks high-Ram for my 6.0L with the 03 motor... and I need to know if this is the right part, I am under the impression that there is two versions for the 6.0 motor... anyone that can verify this PLEASE HELP!

here my part


and heres my motor
If it is a stock 03 motor then that is the right one. If you have removed the throttle body then it will not fit. That is the difference between the two. The ones for the 05-07 trucks are taller and have a different bolt pattern because it mounts lower due to the throttle body being gone.
Reply With Quote Quick reply to this message
  #4  
Old 08-23-2008, 10:30 PM
Compression Ignition Addict
 

Join Date: May 2008
Posts: 178
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks, I got it in... took about 2 hours I had to fight with my intake, the K&N became mangled some how and I had to repair that before I could reinstall the shroud.


Reply With Quote Quick reply to this message
  #5  
Old 08-24-2008, 08:04 AM
Premium Member
 

Join Date: Sep 2007
Location: cape may nj
Posts: 2,301
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
did you notice any changes with it?
Reply With Quote Quick reply to this message
  #6  
Old 08-24-2008, 08:15 AM
Compression Ignition Addict
 

Join Date: May 2008
Posts: 178
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have'nt yet, I have to drive it today. I stupidly pulled my batteries without going back to stock with my programmer. I sure hope that didnt affect anything. I rechipped it and it says it took it. we'll see! Currently I didnt go too far with my test drive so I am hoping the truck is still in its "learning phase" I will update in a few days after I get some miles on the truck.
Reply With Quote Quick reply to this message
  #7  
Old 08-24-2008, 08:29 AM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: Sanford, NC
Posts: 458
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Make sure you get those clamps tight, i blew the tube off on my first real hard run after i put mine on, Looks good and it made a diffrence on mine for sure.
Reply With Quote Quick reply to this message
  #8  
Old 08-24-2008, 12:13 PM
Compression Ignition Addict
 

Join Date: Jul 2007
Posts: 1,314
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Disconnecting the batteries won't lose the program in the PCM, so you're fine. All it did was set the battery disconnect code and reset the emissions stuff. I will relearn after a little driving.

I'm curious about the elbow myself. Let us know if you notice any difference.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:41 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors