Multiple problems!! Bad injector!!! - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-28-2013, 05:18 PM
Member
 

Join Date: Mar 2011
Posts: 76
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Multiple problems!! Bad injector!!!

First off I have a 03 f250 250k stock headgaskets/tty bolts/ egr/ and injectors, sct tuned, today as I left work I noticed she was smoking a lil at start up I thought maybe it was just cause it was a lil cooler out, guess not she's pouring white smoke that smells like straight diesel, there was no check engine light went ahead and checked it with the sct and it's saying cylinder 8 contribution, got up under the truck and there is something leaking out of the cylinder 8 exhaust port which is diesel I think. Should I upgrade, or replace the set with another set of stock replacements, or just replace the single one. I've got a good line on a set 205/100 warren injectors can I tune them down a lil until I upgrade the turbo?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-28-2013, 05:34 PM
Compression Ignition Addict
 

Join Date: Sep 2013
Location: southern va
Posts: 599
Thanks: 4
Thanked 14 Times in 14 Posts
Feedback Score: 0 reviews
i would replace the one, and i would spend money in studs & egr delete befor buyin 205/100s.
Reply With Quote Quick reply to this message
  #3  
Old 10-28-2013, 06:02 PM
Premium Member
 

Join Date: Dec 2012
Location: Ohio
Posts: 294
Thanks: 0
Thanked 13 Times in 12 Posts
Feedback Score: 0 reviews
You need all the right supporting mods before you can throw 205s in. I would just replace that one bad one and work on getting all the other supporting mods next
Reply With Quote Quick reply to this message
  #4  
Old 10-28-2013, 06:25 PM
Member
 

Join Date: Mar 2011
Posts: 76
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm gonna do studs and and delete egr this December when I have two weeks off from work
Reply With Quote Quick reply to this message
  #5  
Old 10-28-2013, 06:37 PM
Serving Our Country!
 

Join Date: Nov 2012
Location: Travis Air Force Base
Posts: 1,858
Thanks: 79
Thanked 93 Times in 58 Posts
Feedback Score: 0 reviews
those are rather larger injectors for a stock truck in my opinion... I would get everything sorted out with the bad injector first and save your money until you have everything you need for that size of injectors etc...
Reply With Quote Quick reply to this message
  #6  
Old 10-30-2013, 03:40 PM
Premium Member
 

Join Date: Oct 2013
Posts: 12
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
my 2005 said cylinder number 8 low contribution so I replaced it with a re-built and it still shows up low contribution and still has a miss. checked the FICM and its in spec, not too sure where to go from there, I don't know if any of yall had any ideas so I figured id ask... thanks
Reply With Quote Quick reply to this message
  #7  
Old 10-30-2013, 04:01 PM
Premium Member

 

Join Date: Sep 2008
Location: Oakbank, Manitoba
Posts: 2,968
Thanks: 6
Thanked 82 Times in 76 Posts
Feedback Score: 0 reviews
Quote:
my 2005 said cylinder number 8 low contribution so I replaced it with a re-built and it still shows up low contribution and still has a miss. checked the FICM and its in spec, not too sure where to go from there, I don't know if any of yall had any ideas so I figured id ask... thanks
Reply With Quote
You should start your own thread.

The OP probably has a cracked nozzle. Let's hope it is just that.

Now for the Hijacker... Check your wiring. Check your FICM by swapping out with a known good one. Do a compression test.
Reply With Quote Quick reply to this message
  #8  
Old 10-31-2013, 06:22 AM
Premium Member
 

Join Date: Mar 2013
Location: Miami, Fl
Posts: 573
Thanks: 3
Thanked 5 Times in 5 Posts
Feedback Score: 2 reviews
change the inj to another cylinder to see if the problem chases it (im tacking the same thing right now)
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:02 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors