injector o ring question ? - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 09-21-2013, 09:05 AM Thread Starter
Member
 
Join Date: May 2010
Location: Greenbrier
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
injector o ring question ?

I had my injectors rebuilt and took them to 155/30 last summer. So far I have had to replace the o ring on top of number 8 injector once last fall and now I am replacing the rest today.

My question is, has anyone else had this problem after you had the injectors rebuilt and if there is a pattern, or just a fluke with me?

At the time I replaced the number 8 injector o ring I had an old set of injectors and pulled an o ring from one of them. I pulled that o ring and looked at it this time, it still looks good so I don't think its the o ring on the oil rail nipple just above the injector.

Does any one have a suggestion why it's eating o rings, it looks like it is wearing from the top down.

Dave

06 350 cc/sw/short bed, 155/30 warrens, arp studs, edge insight cts, modified intake no egr valve or a place to put it, egr delete, blue spring up date, sct with Vivians tunes, PHP ficm programer, AE scan tool, 3" down pipe 4"back magna flow muffler, ccv mod, pyro, 6.4 banjos, ipr coolant filter, stand pipes and dummy plugs, updated hpop fitting
Daves06 is offline  
post #2 of 4 Old 09-21-2013, 11:57 AM
Compression Ignition Addict
 
mechanix's Avatar
 
Join Date: May 2010
Location: Springport MI
Posts: 226
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
I had this happen. Its the orings on the nipples that feed oil to the injectors. I changed all the nipples and o-rings for around 400 or so. I can post up some pics if you like.

Eric

03 F350 Super Duty
ARP head studs
Warren 155/30% injectors
Barder Stage 2 turbo
SCT Tuner
EGR delete
35x12.50x20 Nitto Trail Grapplers
03' No start when hot, ok when cold
mechanix is offline  
post #3 of 4 Old 09-21-2013, 12:12 PM
Premium Member

 
twoicebergs's Avatar
 
Join Date: Sep 2008
Location: Oakbank, Manitoba
Posts: 3,434
Thanks: 8
Thanked 125 Times in 117 Posts
Mentioned: 4 Post(s)
Quoted: 37 Post(s)
Feedback Score: 0 reviews
It is quite possible the cup seals are leaking and spraying HP oil on the injector to cup seal. It might just be nicks or damage on the installation of the rail.

Frank
2007 F-250 Lariat Crew. MBM 190/50s,
KC-68 Stage 3 Turbo,
DashBoss/F/P, and a few other goodies
Stiction Problems - Fix it yourself! - http://www.powerstroke.org/forum/gen...ml#post4509754
Want to modify your injectors DIY - http://www.powerstroke.org/forum/6-0...ger-flows.html

Working for Toys
twoicebergs is online now  
post #4 of 4 Old 09-21-2013, 01:20 PM
Powerstroke Techie


 
JUGERNAUT's Avatar
 
Join Date: Jan 2011
Location: UPPER SALFORD PA
Posts: 2,042
Thanks: 81
Thanked 68 Times in 37 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 13 reviews
Quote:
Originally Posted by mechanix View Post
I had this happen. Its the orings on the nipples that feed oil to the injectors. I changed all the nipples and o-rings for around 400 or so. I can post up some pics if you like.
He is correct


2001 to 2015 SENIOR MASTER TECHNICIAN
BEEN WITH FORD 27 YEARS:
PROUD NAVY VET= ANTI SUBMARINE WARFARE
A/C ASW A/W WINGS

2003 F250 AND I HATE IT. IT ROBS ME BEFORE I GET TO BANK!
JUGERNAUT is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome