03 turbo going quiet?? - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-22-2013, 07:38 AM
Compression Ignition Addict
 

Join Date: Jun 2012
Location: Trinidad Colorado ,USA
Posts: 5,469
Thanks: 113
Thanked 143 Times in 141 Posts
Feedback Score: 0 reviews
03 turbo going quiet??

What would cause a turbo that is producing great boost (25 @ 6000') dosnt seem to have any leaks but, it just dosnt sound as loud as when I first installed it. Ecspecially at idle. Is this possible? What would cause this?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-22-2013, 07:40 AM
Compression Ignition Addict
 

Join Date: Feb 2012
Location: sacramento
Posts: 2,097
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 1 reviews
Maybe you are getting used to it? maybe load the stock tune and switch back?
Reply With Quote Quick reply to this message
  #3  
Old 08-22-2013, 07:45 AM
Compression Ignition Addict
 

Join Date: Jun 2012
Location: Trinidad Colorado ,USA
Posts: 5,469
Thanks: 113
Thanked 143 Times in 141 Posts
Feedback Score: 0 reviews
I might be...truck not tuned yet
Reply With Quote Quick reply to this message
  #4  
Old 08-22-2013, 09:04 AM
RollinEarly05...now


 

Join Date: May 2008
Location: Klamath Falls
Posts: 3,311
Thanks: 27
Thanked 23 Times in 22 Posts
Feedback Score: 10 reviews
Quote:
Originally Posted by kinnisoj View Post
I might be...truck not tuned yet
What's that like?
Reply With Quote Quick reply to this message
  #5  
Old 08-22-2013, 09:36 AM
Compression Ignition Addict
 

Join Date: Feb 2013
Location: Thornton, Colorado
Posts: 279
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
old age = loss of hearing
Reply With Quote Quick reply to this message
  #6  
Old 08-22-2013, 01:37 PM
Compression Ignition Addict
 

Join Date: Jun 2012
Location: Trinidad Colorado ,USA
Posts: 5,469
Thanks: 113
Thanked 143 Times in 141 Posts
Feedback Score: 0 reviews
I wont argue that Im getting old... but the turbo at idle just dosnt sing like it did.
Reply With Quote Quick reply to this message
  #7  
Old 08-22-2013, 02:11 PM
Compression Ignition Addict
 

Join Date: Mar 2007
Location: Edmonton, AB
Posts: 162
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Maybe the vanes are stuck so it's not cycling while idling. Mine will cycle between 15% and 85% most of the time and sometimes it will just sit at 67% and be happy there.
Reply With Quote Quick reply to this message
  #8  
Old 08-22-2013, 02:40 PM
Powerstroke Techie

 

Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,202
Thanks: 21
Thanked 72 Times in 63 Posts
Feedback Score: 4 reviews
The turbo could be stuck in the perfect spot. Believe me, it happens. I recently cleaned a turbo in a 6-speed truck that definitely had a negative affect on performance. It's really hard to explain to a customer that their truck runs worse now after I "fixed" it.


The whistle at idle is caused by the vanes being all the way closed creating the most backpressure and it needs the highest VGT duty cycle to do that.
Reply With Quote Quick reply to this message
  #9  
Old 08-22-2013, 03:47 PM
Serving Our Country!
 

Join Date: Nov 2012
Location: Travis Air Force Base
Posts: 1,858
Thanks: 79
Thanked 93 Times in 58 Posts
Feedback Score: 0 reviews
I think my hearing got a little worse too because im getting proper vgt% and it just doesnt seem as loud anymore haha no one else thinks that though
Reply With Quote Quick reply to this message
  #10  
Old 08-22-2013, 04:20 PM
Compression Ignition Addict
 

Join Date: Jun 2012
Location: Trinidad Colorado ,USA
Posts: 5,469
Thanks: 113
Thanked 143 Times in 141 Posts
Feedback Score: 0 reviews
Ok if I remember correctly I saw the vgt% on my Edge CTS. What should it read?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:45 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors