Edge CTS problem - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-04-2013, 04:59 PM
Premium Member
 

Join Date: Apr 2011
Location: Concord, Ohio
Posts: 194
Thanks: 11
Thanked 5 Times in 4 Posts
Feedback Score: 0 reviews
Edge CTS problem

Hello everyone, I went to update my CTS today and it went dead. First the Fusion software updated then I connected the CTS. It said there were updates to it and downloaded and installed them. Then the screen went blank and it beeps every 10 seconds. Tried everything again and it just says Recovery Mode Resetting on the Fusion software and nothing. Tried uninstalling and reinstalling Fusion software with no luck. Tried putting it back in the truck and same thing, blank screen and beeping every few seconds. Guess I'll call Edge tomorrow. Has anyone had this happen before? I update it every couple months and this a first.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-04-2013, 05:05 PM
Compression Ignition Addict
 

Join Date: Feb 2008
Posts: 8,446
Thanks: 72
Thanked 215 Times in 203 Posts
Feedback Score: 0 reviews
We learned never update devices on weekends LOL

they will get you dialed in Monday
Reply With Quote Quick reply to this message
  #3  
Old 08-04-2013, 05:06 PM
Premium Member
 

Join Date: Apr 2011
Location: Concord, Ohio
Posts: 194
Thanks: 11
Thanked 5 Times in 4 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by ZMANN View Post
We learned never update devices on weekends LOL

they will get you dialed in Monday
LOL. Yeah, just has some free time while the wife was at work and then I end up messing with it for hours. Oh well.
Reply With Quote Quick reply to this message
  #4  
Old 08-04-2013, 05:36 PM
Compression Ignition Addict
 
Join Date: Oct 2006
Location: Humboldt, California
Posts: 2,173
Thanks: 127
Thanked 10 Times in 9 Posts
Feedback Score: 1 reviews
Mine did this the other day. Called them once and they said give it time to do the recovery mode so I said okay. Gave it an hour when they said 20min is usually enough. Nothing. Called again and they said call us when your next to your computer and we'll try and walk you through it. Wasnt happy but ok. Finally got off from work early enough to get home while they where open and the guy says oh we'll just send you a new one and you send us your old one back! Didn't even try to troubleshoot it. Could have done that a week ago.... so ya long story short call them.

Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:58 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors