More Airdog BS!!! - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-19-2013, 08:37 PM
Premium Member

 

Join Date: Jun 2009
Location: Charleston, SC
Posts: 140
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
More Airdog BS!!!

So I've had an airdog 2 on my truck from early 2012 until June 2013 working without problems until the fuse blew. So I did some research and found that many were having problems. I called airdog and asked them about it and they told me that in August of 2012 they came out with an "updated" unit. So I am working overseas and cannot do anything myself, so I have a trusted mechanic that does my work for me. He installed the new unit, did the relay and upgraded the wiring harness and reset the fuel pressure back to normal. He primed the truck and went to fire it up and during cranking it dropped from 60psi to 10psi. So he took the new unit off and replaced with the old and fired it up and it held 60psi the entire time. So this supposedly "brand new" airdog unit is screwed from the start and now I have to get another one from them and they are closed on weekends and I'm pissed because now its just a mess.

Anybody else with similar issues? When I get home I am going to disassemble the original one and figure out if I can replace the gerator pump, rewire and reassemble with with a brushless motor and upgraded wiring and try to make a one-off airdog unit. I'm not sure if it can be done but I'm going to give it the ol' college try and see if anything good comes of it. Anybody else try to take one apart and rebuild?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-19-2013, 09:33 PM
Compression Ignition Addict
 

Join Date: May 2011
Location: Rocklin, CA (Sacramento Area)
Posts: 826
Thanks: 2
Thanked 16 Times in 14 Posts
Feedback Score: 3 reviews
It is a common story .... A more reliable setup seems to be using the 6.4 pump as a lift pump feeding the stock hfcm .... If big hp is your goal look into a fuel lab pump setup. I myself would sh!t can anything that said airdog if it were on my truck.
Reply With Quote Quick reply to this message
  #3  
Old 07-20-2013, 02:43 AM
N.S.D.Q.
 

Join Date: Oct 2007
Location: Middle VA
Posts: 3,838
Thanks: 5
Thanked 37 Times in 28 Posts
Feedback Score: 3 reviews
My AD100 seems to do it's job quite well. Another buddy has been running the AD150 for awhile too with no issues. AD II units are the problem child not AirDog in general.
Reply With Quote Quick reply to this message
  #4  
Old 07-20-2013, 07:06 AM
Compression Ignition Addict
 

Join Date: May 2011
Location: Rocklin, CA (Sacramento Area)
Posts: 826
Thanks: 2
Thanked 16 Times in 14 Posts
Feedback Score: 3 reviews
Based on pure flows record of some garbage products and even more pathetic customer service I wouldn't give them a dime of my money. And if it was on the truck working perfect or not it would have hit the bottom of my garbage can!
Reply With Quote Quick reply to this message
  #5  
Old 07-20-2013, 08:05 AM
Premium Member

 

Join Date: Jun 2009
Location: Charleston, SC
Posts: 140
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yeah I just haven't heard of anybody coming out and saying "THIS is the right setup, use THIS" so it's kind of hit or miss. I hear FASS is just as bad and I was finding some things on here about fuel lab being somewhat new with their water separator I don't want to be the guinea pig that buys yet another unit for more failing crap.

Hopefully somebody has used the fuel lab setup and will chime in here and give their
Reply With Quote Quick reply to this message
  #6  
Old 07-20-2013, 09:10 AM
Bump To Pass!!


 

Join Date: Jan 2010
Location: Monroe, WA
Posts: 3,555
Thanks: 42
Thanked 166 Times in 153 Posts
Feedback Score: 1 reviews
My AD2 is now a lift pump turned all the way down to my factory HCFM. Never drops bleow 60psi with this setup even at WOT.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:44 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors