SCT Questions - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 04-14-2008, 02:14 PM Thread Starter Fanatic
Jetmek319's Avatar
Join Date: Sep 2007
Location: Denver, CO
Posts: 125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to Jetmek319 Send a message via Yahoo to Jetmek319
SCT Questions

I've got my Livewire hooked in a running and love it. One of the performance monitors (PID's) that I have displayed is the engine coolant temp. When the engine is at normal operating temp the display reads 190.0 degrees....never 190.1 or 189.9, always exactly 190.0, every time. It doesn't make a difference if its 70 or 20 outside, a/c running, uphill, downhill, or heavily loaded. I have never been around and engine that has that kind of precise control over the temps. It's almost as if the sensors and computer have put a limit on the readout. Anybody else experiencing this???

Never, ever moon a werewolf!!!

2004 F250 SD 6.0 Crew SB,
Auto, CX Gray, AFE Stg II, 4" Turbo back MBRP exhaust, Stage I Fuel mod, Gunner Chrome, Recon Plastics, Marinco mod, Rhino Lined, DBA/Hawk Brakes, SCT Livewire w/ Elite Diesel Toons , A.R.E Bedcap, Mag Hy-Tec Diff cover, Home Engineered Oil Bypass System, Kenwwod DNX5120, Clifford Auto-start, 58V Swamp's FICM.

+ = :burnout
Jetmek319 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome