oil leak - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-03-2013, 01:37 PM
Compression Ignition Addict
 

Join Date: Feb 2012
Location: saint joseph
Posts: 163
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
oil leak

I installed my 190/100's this last week and my mtw stage 3 and I have an oil leak under the turbo area. I pulled the turbo and the orings looked ok on the drain tube, but I had another sitting around so I swapped the orings and it still leaked. And since I didn't have the leak before all of this I decided to put my powermax back on and it leaked also. Now what confuses me is that at an idle it doesn't leak a drop its only while driving which makes finding the source even harder. Everywhere around the valve covers that I can see and injector connectors looks clean. I cleaned the pedestal and drain tube off and went and drove it and there was some oil on them when i got back so i think it has to be the drain tube so I ordered a whole new one from my local ford dealer and it won't be here till Friday I just wanted to get some opinions if it is the drain tube or if I could have another issue. The truck starts just as fast as before once the air got worked out and it runs good.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-05-2013, 10:54 PM
Compression Ignition Addict
 

Join Date: Nov 2012
Posts: 162
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
are you sure its oil and could it be coming from the HPOP cover?

Not trying to insult your intelligence but sometimes things are easy to overlook.
Reply With Quote Quick reply to this message
  #3  
Old 07-05-2013, 10:59 PM
Compression Ignition Addict
 

Join Date: Nov 2012
Posts: 162
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Also, You might wanna pull the tube off of the turbo and see if any oil is leaking from there possibly pooling up at idle then when it boosts it comes out of the boots
Reply With Quote Quick reply to this message
  #4  
Old 07-06-2013, 06:10 AM
Compression Ignition Addict
 

Join Date: Feb 2012
Location: saint joseph
Posts: 163
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It doesn't look like the hpop cover is leaking. And I actually had a little oil pooling on the pedistal right below the drain tube. And when I did my injectors and turbo I didn't mess with the hpop so I kinda assumed that nothing was wrong with it the hpop is only around a year old.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:18 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors