Edge Juice W/ Attitude problem - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-23-2008, 10:44 AM
Powerstroke.org Rookie
 

Join Date: Mar 2007
Location: FLANAGAN, IL
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Edge Juice W/ Attitude problem

I bought one used and it does not appear to work(although did not make a test drive). What I would like to know is do you have to have the toggle switch hook up at the same time as the attitude for it to work? The wires for the toggle have been cut off at the connector, should I splice(cut off the other connector on the switch side) them together so that the switch is active or does it not matter? Does the toggle switch HAVE TO be connected for everything to work? Does this effect the attitude monitor from working or not? The attitude monitor lights up but will not switch between power levels or register anything(rpm, egt ect.). It is an older model EJF1000WAM. The Juice module is EJF1000 ver 2.6 with a date of manuf. of 5/25/04. The attitude monitor is an EAF2000 ver 3.1 with a manuf. date of 5/24/04. I would assume with the manuf. dates so close that they should be right for each other, correct? The truck did start with it hook up. By the way it is a 2003 6.0. Any info would be appreciated! ~Thanks~
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-23-2008, 11:08 AM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: N. Illinois
Posts: 318
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
did you hook up all the Y connectors in the engine bay? I didnt get any toggle switch with mine so I am assuming you will not need this.
Reply With Quote Quick reply to this message
  #3  
Old 03-23-2008, 11:12 AM
Powerstroke.org Rookie
 

Join Date: Mar 2007
Location: FLANAGAN, IL
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What do you mean by "Y" connectors? ~Thanks~
Reply With Quote Quick reply to this message
  #4  
Old 03-23-2008, 11:23 AM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: N. Illinois
Posts: 318
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
the edge chip works off of the factory sensors. I beleive one goes on the cps and other various sensors. It will have a Y adaptor, the factory harness clips in on one side and then the edge clips into the sensor. I believe there are about 4 of them needed.
Reply With Quote Quick reply to this message
  #5  
Old 03-23-2008, 12:15 PM
Powerstroke.org Rookie
 

Join Date: Mar 2007
Location: FLANAGAN, IL
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The back of my Edge only has two sensor wires, one for the map sensor and one for the EGT. I had both of them hooked up at install. ~Thanks again~
Reply With Quote Quick reply to this message
  #6  
Old 03-23-2008, 12:57 PM
Compression Ignition Addict
 

Join Date: Mar 2007
Posts: 4,579
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
it piggy backs into the pcm. if you don't remember plugging it in then it isn't installed. you have to take off the battery cover if I remember correctly.
Reply With Quote Quick reply to this message
  #7  
Old 03-23-2008, 01:50 PM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Location: EUGENE OREGON
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I HAVE A 2003 6.0 F250 FX4 WITH EDGE JUICE PLATINUM WITH ATTITUDE. YOU HAVE TO HAVE THE WIRING HARNESS THAT ALLOWS THE EDGE JUICE TO TIE INTO YOUR FACTORY WIRING HARNESS. THIS TAKES PLACE ON THE DRIVERS SIDE UNDERNEATH THE BATTERY COVER, BETWEEN BATTERY AND FENDER WELL. YOU UNPLUG THE TWO CONNECTORS CLOSET TO THE CAB AND TEE IN THE EDGE HARNESS AND THEN PLUG THE EDGE HARNESS INTO YOUR EDGE MODULE. ON THE BACK SIDE OF THE EDGE MODULE THERE ARE TWO LEADS ONE GOES TO THE ATTITUDE MODULE THE OTHER GOES TO YOUR EGT THERMAL SENSOR WHICH WILL CONNECT TO YOUR EGT PROBE THAT YOU HAVE TO TAP AND DIE INTO THE DRIVERS SIDE EXAUST MANIFOLD. THERE ARE NO TOGGLES OR SWITCHES, YOUR ATTITUDE MONITER TAKES CARE OF ALL ADJUSTMENT OR ON AND OFF CHOICES YOU CHOOSE TO MAKE. BY THE WAY MY TRUCK IS RUNNING 13.9. I HAVE A 4" TURBO BACK MBRP AND AN AIRRAID INTAKE WITH DIRECT AIR INJECTION.
Reply With Quote Quick reply to this message
  #8  
Old 03-23-2008, 02:26 PM
Powerstroke.org Rookie
 

Join Date: Mar 2007
Location: FLANAGAN, IL
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by darsey715 View Post
it piggy backs into the pcm. if you don't remember plugging it in then it isn't installed. you have to take off the battery cover if I remember correctly.
Correct, removed middle connection and put on left side of edge and then that into the middle space and the the stock into right side of edge. Hooked up lead to MAP and EGT. Does every one else still have their toggle switches(if so equipped) connected? ~Thanks darsey715~
Reply With Quote Quick reply to this message
  #9  
Old 03-23-2008, 02:29 PM
Powerstroke.org Rookie
 

Join Date: Mar 2007
Location: FLANAGAN, IL
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by cgarcon View Post
I HAVE A 2003 6.0 F250 FX4 WITH EDGE JUICE PLATINUM WITH ATTITUDE. YOU HAVE TO HAVE THE WIRING HARNESS THAT ALLOWS THE EDGE JUICE TO TIE INTO YOUR FACTORY WIRING HARNESS. THIS TAKES PLACE ON THE DRIVERS SIDE UNDERNEATH THE BATTERY COVER, BETWEEN BATTERY AND FENDER WELL. YOU UNPLUG THE TWO CONNECTORS CLOSET TO THE CAB AND TEE IN THE EDGE HARNESS AND THEN PLUG THE EDGE HARNESS INTO YOUR EDGE MODULE. ON THE BACK SIDE OF THE EDGE MODULE THERE ARE TWO LEADS ONE GOES TO THE ATTITUDE MODULE THE OTHER GOES TO YOUR EGT THERMAL SENSOR WHICH WILL CONNECT TO YOUR EGT PROBE THAT YOU HAVE TO TAP AND DIE INTO THE DRIVERS SIDE EXAUST MANIFOLD. THERE ARE NO TOGGLES OR SWITCHES, YOUR ATTITUDE MONITER TAKES CARE OF ALL ADJUSTMENT OR ON AND OFF CHOICES YOU CHOOSE TO MAKE. BY THE WAY MY TRUCK IS RUNNING 13.9. I HAVE A 4" TURBO BACK MBRP AND AN AIRRAID INTAKE WITH DIRECT AIR INJECTION.
I do not have the "Platinum" version and have tapped my manifold for the probe. I do have a toggle switch, it is used without the attitude monitor and supplies 3 power levels without the monitor. ~Thanks for your help~
Reply With Quote Quick reply to this message
  #10  
Old 03-23-2008, 04:10 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Las Vegas,NV
Posts: 259
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i still have (but don't use) an EJF1000WAM(EJA1000 & EAF2000)...these models DO have a toggle switch for changing power levels without the Attitude monitor..in the manual it states that the toggle switch is disabled when the Attitude is connected, and doesn't need to be in any certain position...disabled or not, you might want to make sure the wires are not shorting to each other/safed off..

the manual does state that if your PCM connections aren't correct, it will run at stock power levels or not start, and you'll have no rpm display...

the guys at Edge are pretty cool...if you call them tomorrow, they should be willing to help..
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:45 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors