F'n Pureflow strikes again! - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-09-2013, 01:40 PM
Super Moderator


 

Join Date: Mar 2008
Location: Abingdon, Md.
Posts: 11,971
Thanks: 3
Thanked 29 Times in 15 Posts
Feedback Score: 3 reviews
F'n Pureflow strikes again!

I've freaking had it. Was out playing trucks with Greg today. Actually he was working and I was kibitzing. Finished flushing the truck and refilled with Delo ELC. Went to start it up and fuel pressure only went to 30 psi. Fuelab Prodigy pump sounded really weird. Greg says "your Fuelab is messed up". tell him "no, it's the Airdog".

Let me refresh your memories. This is my 3rd ADII DF-165, and I had to pay for this replacement over some warranty card BS. Last July I went up to Upstate NY to get a border collie that my wife's uncle couldn't care for anymore. When I went to leave no fuel pressure. ADII dead as a door nail. After going round and round with Pureflow I had to by a replacement pump and overnight it to NY. No option. Ok I drive the truck home to Baltimore and essentially tear it apart for some serious upgrades. One of those upgrades was to demote my new ADII to a low pressure lift pump function and feed a new Fuelab high pressure pump. So while this ADII is 11 months old it has less than 1000 miles on it.

So I have Greg turn the fuel pressure screw in 1/2 turn. No difference. So I have him crack the fuel feed line on the Fuelab from the ADII. It finally starts spitting fuel so we tighten it down and BINGO I have 50 PSI again and all is good. Turn it off and let it sit for a minute, try to restart, same thing. We go through this for 1/2 hr., maybe 4 times and it holds for 5 minutes. I wouldn't bet that it will be working when I try to start it up again.

So that's it for me and Pureflow. I am going to warranty the ADII and put it on e-Bay brand new in the box and get what I can out of it. I will be building a new filter setup for the Fuelab and be done with it.

Pureflow needs to be put out of business. They know and have known for years this pump is a pos and refuse to fix it. I will never buy another product from Pureflow and recommend anybody that is looking to do fuel system upgrades to stay far away fro Pureflow. Everything about this company sucks.

OK, rant over.

Last edited by PGreenSVT; 06-09-2013 at 01:44 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-09-2013, 01:55 PM
MARSOC > Seals



 

Join Date: Dec 2006
Location: Solsberry, IN
Posts: 7,014
Thanks: 3
Thanked 56 Times in 39 Posts
Feedback Score: 0 reviews
That sucks. Sorry to hear. I'm on my 3rd ADII and this one has gave me no problems yet. Fingers crossed. I don't know what route I would go if it takes another dump on me.
Reply With Quote Quick reply to this message
  #3  
Old 06-09-2013, 02:32 PM
Compression Ignition Addict
 

Join Date: Apr 2010
Location: Evansville, IN
Posts: 1,016
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
^ it's pretty sad to have your fingers crossed that an aftermarket fuel pump will not sh*t out on you while driving. Good luck to you though hope it works out, whenever my oem unit goes out I will probably just go oem again , definitely not AD
Reply With Quote Quick reply to this message
  #4  
Old 06-09-2013, 02:46 PM
Serving Our Country!
 

Join Date: Nov 2012
Location: Travis Air Force Base
Posts: 1,853
Thanks: 79
Thanked 93 Times in 58 Posts
Feedback Score: 0 reviews
good to know about the ad fuel system and will not be looking to them.

Sorry Dieselburner21 I love the star trek meme pic thing ahahahaha im a bit of a nerd so it got me bad.

sorry for the squirrel.
Reply With Quote Quick reply to this message
  #5  
Old 06-09-2013, 02:58 PM
Bump To Pass!!


 

Join Date: Jan 2010
Location: Monroe, WA
Posts: 3,813
Thanks: 45
Thanked 203 Times in 185 Posts
Feedback Score: 1 reviews
I know how you feel Mitch. I just demoted my AD2 to a lift pump for the factory HCFM. So far it works great. I am pissed I have an 800.00 lift pump now.
Reply With Quote Quick reply to this message
  #6  
Old 06-09-2013, 03:18 PM
Compression Ignition Addict
 

Join Date: Jul 2011
Location: Tuscaloosa, Al
Posts: 1,398
Thanks: 2
Thanked 17 Times in 14 Posts
Feedback Score: 0 reviews
I am also on my 3rd AD-165 and two days ago I roll into the throttle to pass someone and my fuel pressure drops to 20psi! Since then anything over 1/4 throttle drops the pressure from 58 down to around 20 immediately. I HATE AIRDOG and would not recommend their pump to anyone. Complete waste of money.
Reply With Quote Quick reply to this message
  #7  
Old 06-09-2013, 03:22 PM
My 6OH Hates Me


 

Join Date: Sep 2007
Location: Nexus of the Universe
Posts: 24,713
Thanks: 8
Thanked 16 Times in 15 Posts
Feedback Score: 1 reviews
Sorry to hear mitch. although I am on my 2nd pump, I have put about 150k on my ad165. The 2nd pump is running fine.
Reply With Quote Quick reply to this message
  #8  
Old 06-09-2013, 04:00 PM
Powerstroke Techie

 

Join Date: Aug 2010
Location: Sassamansville, Pa
Posts: 9,665
Thanks: 85
Thanked 183 Times in 147 Posts
Feedback Score: 3 reviews
Mitch, do you plan on dissecting the failed motor? I wonder if its the seal.


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #9  
Old 06-09-2013, 06:04 PM
Super Moderator


 

Join Date: Mar 2008
Location: Abingdon, Md.
Posts: 11,971
Thanks: 3
Thanked 29 Times in 15 Posts
Feedback Score: 3 reviews
No Rich. It's under warranty. I am sending it in for replacement and then putting the new one on eBay to recoup whatever I can from this debacle.
Reply With Quote Quick reply to this message
  #10  
Old 06-09-2013, 06:06 PM
MARSOC > Seals



 

Join Date: Dec 2006
Location: Solsberry, IN
Posts: 7,014
Thanks: 3
Thanked 56 Times in 39 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Lilpooh View Post
Mitch, do you plan on dissecting the failed motor? I wonder if its the seal.


Sent from AutoGuide.com Free App
They said that they fixed that issue. I'm wondering if Mitch's was one of the "newer" ones. Once I heard about them "fixing" the problem, I called them to ask if mine had the newer seal in it and they said yes. No problems yet. On a side note, I have heard they have a dumpster out back that is just full of returned pumps. You would think that they would want to fix the issue and keep customers. Guess not.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:59 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors