F'n Pureflow strikes again! - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 37 Old 06-09-2013, 01:40 PM Thread Starter
Super Moderator


 
PGreenSVT's Avatar
 
Join Date: Mar 2008
Location: Abingdon, Md.
Posts: 11,991
Thanks: 4
Thanked 48 Times in 19 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 3 reviews
F'n Pureflow strikes again!

I've freaking had it. Was out playing trucks with Greg today. Actually he was working and I was kibitzing. Finished flushing the truck and refilled with Delo ELC. Went to start it up and fuel pressure only went to 30 psi. Fuelab Prodigy pump sounded really weird. Greg says "your Fuelab is messed up". tell him "no, it's the Airdog".

Let me refresh your memories. This is my 3rd ADII DF-165, and I had to pay for this replacement over some warranty card BS. Last July I went up to Upstate NY to get a border collie that my wife's uncle couldn't care for anymore. When I went to leave no fuel pressure. ADII dead as a door nail. After going round and round with Pureflow I had to by a replacement pump and overnight it to NY. No option. Ok I drive the truck home to Baltimore and essentially tear it apart for some serious upgrades. One of those upgrades was to demote my new ADII to a low pressure lift pump function and feed a new Fuelab high pressure pump. So while this ADII is 11 months old it has less than 1000 miles on it.

So I have Greg turn the fuel pressure screw in 1/2 turn. No difference. So I have him crack the fuel feed line on the Fuelab from the ADII. It finally starts spitting fuel so we tighten it down and BINGO I have 50 PSI again and all is good. Turn it off and let it sit for a minute, try to restart, same thing. We go through this for 1/2 hr., maybe 4 times and it holds for 5 minutes. I wouldn't bet that it will be working when I try to start it up again.

So that's it for me and Pureflow. I am going to warranty the ADII and put it on e-Bay brand new in the box and get what I can out of it. I will be building a new filter setup for the Fuelab and be done with it.

Pureflow needs to be put out of business. They know and have known for years this pump is a pos and refuse to fix it. I will never buy another product from Pureflow and recommend anybody that is looking to do fuel system upgrades to stay far away fro Pureflow. Everything about this company sucks.

OK, rant over.

Last edited by PGreenSVT; 06-09-2013 at 01:44 PM.
PGreenSVT is offline  
post #2 of 37 Old 06-09-2013, 01:55 PM
Marine Raiders>Seals



 
najaf4life's Avatar
 
Join Date: Dec 2006
Location: Solsberry, IN
Posts: 7,120
Thanks: 4
Thanked 66 Times in 49 Posts
Mentioned: 2 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
That sucks. Sorry to hear. I'm on my 3rd ADII and this one has gave me no problems yet. Fingers crossed. I don't know what route I would go if it takes another dump on me.

RYAN
03 Excursion 6.0L

BPD,WPE & other odds and ends
najaf4life is offline  
post #3 of 37 Old 06-09-2013, 02:32 PM
Compression Ignition Addict
 
dieselburner21's Avatar
 
Join Date: Apr 2010
Location: Evansville, IN
Posts: 1,119
Thanks: 1
Thanked 6 Times in 6 Posts
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
Feedback Score: 0 reviews
^ it's pretty sad to have your fingers crossed that an aftermarket fuel pump will not sh*t out on you while driving. Good luck to you though hope it works out, whenever my oem unit goes out I will probably just go oem again , definitely not AD

Will

2010 FORD F250 LARIAT CCSB 6.4
-H&S Mini Maxx / Edge Insight CTS / 4" Flo Pro Dump / 20" Fuel Hostages / 33" Toyo AT's / Airdog II 4G

2006 FORD F250 LARIAT CCSB 6.0 - TRADED

2000 FORD F250 LARIAT CCSB 7.3 - SOLD
dieselburner21 is offline  
post #4 of 37 Old 06-09-2013, 02:46 PM
Serving Our Country!
 
JustinOOO9's Avatar
 
Join Date: Nov 2012
Location: Yuba City
Posts: 2,653
Thanks: 115
Thanked 140 Times in 103 Posts
Mentioned: 4 Post(s)
Quoted: 166 Post(s)
Garage
Feedback Score: 1 reviews
good to know about the ad fuel system and will not be looking to them.

Sorry Dieselburner21 I love the star trek meme pic thing ahahahaha im a bit of a nerd so it got me bad.

sorry for the squirrel.

-2004 F350 CCLB 4x4: Sinister Race solutions kit, CAT ELC Edge CS, SCT SF3, PHP Ficm programmer, Procomp, Rough country, and Nitto goodies.
-2004 excursion, banks exhaust, 03 turbo, afe intake
-2006 f350 king ranch, 10 in fabtech, 40in tires, sct tunes,

currently-1999 F250 SBRB 4X4 First 7.3 and feels good to be back in a diesel....

Interested in learning something new?

http://www.powerstroke.org/forum/pol...verse-day.html


Justin,
JustinOOO9 is offline  
post #5 of 37 Old 06-09-2013, 02:58 PM
Bump To Pass!!




 
toren302's Avatar
 
Join Date: Jan 2010
Location: Monroe, WA
Posts: 11,186
Thanks: 122
Thanked 903 Times in 802 Posts
Mentioned: 130 Post(s)
Quoted: 1123 Post(s)
Feedback Score: 1 reviews
I know how you feel Mitch. I just demoted my AD2 to a lift pump for the factory HCFM. So far it works great. I am pissed I have an 800.00 lift pump now.




toren302 is offline  
post #6 of 37 Old 06-09-2013, 03:18 PM
Compression Ignition Addict
 
Dirty_Stroke's Avatar
 
Join Date: Jul 2011
Location: Tuscaloosa, Al
Posts: 1,398
Thanks: 2
Thanked 17 Times in 14 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I am also on my 3rd AD-165 and two days ago I roll into the throttle to pass someone and my fuel pressure drops to 20psi! Since then anything over 1/4 throttle drops the pressure from 58 down to around 20 immediately. I HATE AIRDOG and would not recommend their pump to anyone. Complete waste of money.



05 F250 FX4 Lariat, SCT Livewire, 155cc injectors, Gryphon FICM tuner, ARP studs, MTW Stage 2 Turbo, Riff Raff boots, Warren Built trans, PMF traction bars ,4 inch straight pipe, Sinister EGR delete, S&B CAI, N-fab bars, level kit, 5% limo tint, 35 Toyos and 20s, Recon smoked everything, Harley headlights, 5k HID's, Camlocker toolbox, lots more
Dirty_Stroke is offline  
post #7 of 37 Old 06-09-2013, 03:22 PM
My 6OH Hates Me


 
mudrunninpig's Avatar
 
Join Date: Sep 2007
Location: Nexus of the Universe
Posts: 24,836
Thanks: 8
Thanked 27 Times in 26 Posts
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
Feedback Score: 1 reviews
Sorry to hear mitch. although I am on my 2nd pump, I have put about 150k on my ad165. The 2nd pump is running fine.

Mike




"The Iron Pig"



mudrunninpig is offline  
post #8 of 37 Old 06-09-2013, 04:00 PM
Powerstroke Techie

 
Lilpooh's Avatar
 
Join Date: Aug 2010
Location: Sassamansville, Pa
Posts: 9,787
Thanks: 95
Thanked 195 Times in 157 Posts
Mentioned: 2 Post(s)
Quoted: 0 Post(s)
Feedback Score: 3 reviews
Mitch, do you plan on dissecting the failed motor? I wonder if its the seal.


Sent from AutoGuide.com Free App

2004 F350 CC DRW King Ranch
X-3 tunes by DJ'S,QT,GH,ID. Gryphon FICM tunes, ARP studs,Stage 1turbo,ATS coolant recirc lines,Swamp's 48v ficm,coolant filter,AD2,Snow Perf stage II,EGR delete,4" turbo back straight pipe,S&Bintake,Quad "A" pillar autometer gauges,Suncoast Tri Disk Conv.,Billet input shaft,Suncoast superduty rebuild kit,Trans-go shift kit,Mag-Hytec trans pan,CFM+ elbow,ccv mod,15K reese 5er,17" LCD TV/DVD,Cobra 29 Nitewatch CB
Lilpooh is offline  
post #9 of 37 Old 06-09-2013, 06:04 PM Thread Starter
Super Moderator


 
PGreenSVT's Avatar
 
Join Date: Mar 2008
Location: Abingdon, Md.
Posts: 11,991
Thanks: 4
Thanked 48 Times in 19 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 3 reviews
No Rich. It's under warranty. I am sending it in for replacement and then putting the new one on eBay to recoup whatever I can from this debacle.
PGreenSVT is offline  
post #10 of 37 Old 06-09-2013, 06:06 PM
Marine Raiders>Seals



 
najaf4life's Avatar
 
Join Date: Dec 2006
Location: Solsberry, IN
Posts: 7,120
Thanks: 4
Thanked 66 Times in 49 Posts
Mentioned: 2 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Lilpooh View Post
Mitch, do you plan on dissecting the failed motor? I wonder if its the seal.


Sent from AutoGuide.com Free App
They said that they fixed that issue. I'm wondering if Mitch's was one of the "newer" ones. Once I heard about them "fixing" the problem, I called them to ask if mine had the newer seal in it and they said yes. No problems yet. On a side note, I have heard they have a dumpster out back that is just full of returned pumps. You would think that they would want to fix the issue and keep customers. Guess not.

RYAN
03 Excursion 6.0L

BPD,WPE & other odds and ends
najaf4life is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome