AIRDOG 2 NO LONGER!! - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-04-2012, 12:40 PM
Powerstroke Techie


 

Join Date: Jan 2011
Location: UPPER SALFORD PA
Posts: 2,021
Thanks: 80
Thanked 60 Times in 32 Posts
Feedback Score: 13 reviews
Exclamation AIRDOG 2 NO LONGER!!

I will not install any airdog products on any of my customer builds anymore!
Of the 5 ive done so far 4 have failed 2 of which failed this weekend. I know its only a matter of time before mine fails! so i will be looking for another salution for fuel pumps!! one pissed of installer!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-04-2012, 12:51 PM
Member
 

Join Date: Oct 2009
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Keep us posted on what you decide to use for an alternative choice...
Reply With Quote Quick reply to this message
  #3  
Old 12-04-2012, 01:05 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Corvallis, OR
Posts: 3,076
Thanks: 7
Thanked 17 Times in 16 Posts
Feedback Score: 0 reviews
I won't touch them either. Nothing but problems and their customer service sucks.

If anyone has them MAKE SURE YOU SEND IN THE WARRANTY CARD!!!
Reply With Quote Quick reply to this message
  #4  
Old 12-04-2012, 01:41 PM
Super Moderator


 

Join Date: Mar 2008
Location: Abingdon, Md.
Posts: 11,969
Thanks: 3
Thanked 27 Times in 15 Posts
Feedback Score: 3 reviews
Dale, discarding the delivered wiring harness and making your own 10 ga. harness seems to do the trick. Personally I am on my 3rd pump and am installing a 10 gauge harness and demoting it to a low pressure high volume pusher to a Fuelab 41402 high pressure pump.
Reply With Quote Quick reply to this message
  #5  
Old 12-04-2012, 01:58 PM
Powerstroke Techie


 

Join Date: Jan 2011
Location: UPPER SALFORD PA
Posts: 2,021
Thanks: 80
Thanked 60 Times in 32 Posts
Feedback Score: 13 reviews
Quote:
Originally Posted by PGreenSVT View Post
Dale, discarding the delivered wiring harness and making your own 10 ga. harness seems to do the trick. Personally I am on my 3rd pump and am installing a 10 gauge harness and demoting it to a low pressure high volume pusher to a Fuelab 41402 high pressure pump.
Cool ill look that up! Ty
Reply With Quote Quick reply to this message
  #6  
Old 12-04-2012, 02:11 PM
Compression Ignition Addict
 

Join Date: Feb 2008
Location: Keller, Texas
Posts: 2,093
Thanks: 0
Thanked 7 Times in 7 Posts
Feedback Score: 2 reviews
I agree even with the 10 gauge harness my pump died its just a poor piece of equipment
Reply With Quote Quick reply to this message
  #7  
Old 12-04-2012, 03:10 PM
Illiana Chapter Director

 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 12,334
Thanks: 5
Thanked 85 Times in 80 Posts
Feedback Score: 2 reviews
Quote:
Originally Posted by PGreenSVT View Post
Dale, discarding the delivered wiring harness and making your own 10 ga. harness seems to do the trick. Personally I am on my 3rd pump and am installing a 10 gauge harness and demoting it to a low pressure high volume pusher to a Fuelab 41402 high pressure pump.
How will that work if the Fuelab pump only runs @ 45 PSI or is it capable of more? Just curious.
Reply With Quote Quick reply to this message
  #8  
Old 12-04-2012, 04:23 PM
Premium Member
 

Join Date: Jan 2012
Location: Fallon, Nv
Posts: 2,397
Thanks: 51
Thanked 9 Times in 8 Posts
Feedback Score: 0 reviews
What about AD100/150 that use a lift pump? Are those a pile of poo also?

Would a lift pump relieve the load on the AD2?

sent from a dumb guy with a smart phone
Reply With Quote Quick reply to this message
  #9  
Old 12-04-2012, 04:29 PM
BACKYARDIGAN


 

Join Date: Feb 2010
Location: Huntington, WV
Posts: 4,643
Thanks: 27
Thanked 87 Times in 61 Posts
Feedback Score: 2 reviews
Quote:
Originally Posted by Karls03 View Post
What about AD100/150 that use a lift pump? Are those a pile of poo also?
^^^This. Dale are you referring to AD2s (the ones that replace the OEM HFCM) or are the AD100/150s failing on you too??
Reply With Quote Quick reply to this message
  #10  
Old 12-04-2012, 06:21 PM
Powerstroke Techie


 

Join Date: Jan 2011
Location: UPPER SALFORD PA
Posts: 2,021
Thanks: 80
Thanked 60 Times in 32 Posts
Feedback Score: 13 reviews
Quote:
Originally Posted by windrunner408 View Post
^^^This. Dale are you referring to AD2s (the ones that replace the OEM HFCM) or are the AD100/150s failing on you too??
yes airdog 2 165
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:45 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors