ICP IS LOW, HELP!!!!!!! - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-28-2012, 04:13 PM
Member
 

Join Date: Sep 2012
Location: Azle,tx.
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ICP IS LOW, HELP!!!!!!!

I ordered a Livewire TS, with custom tunes. Loaded it on the truck, and it does not run much stronger. I get to looking around, and I find that my ICP is reading 580psi at idle, and no more than 3070psi wide open. Now this is with the truck returned to stock tuning, and the oil temp at 180*. Is the anything else between the HPOP, and the ICP sensor that could drop the pressure? All help is greatly appreciated.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-28-2012, 04:16 PM
Illiana Chapter Director

 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 12,320
Thanks: 5
Thanked 84 Times in 79 Posts
Feedback Score: 2 reviews
Is it setting a low ICP code? Those seem like pretty good numbers
Reply With Quote Quick reply to this message
  #3  
Old 11-28-2012, 04:22 PM
Member
 

Join Date: Sep 2012
Location: Azle,tx.
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No, it is not setting a code yet. But, in the sticky on here it say's it should idle around 650psi and 4050psi at WOT. Also my truck is not responding to the custom tunes very well. it does not make much more power than stock.
Reply With Quote Quick reply to this message
  #4  
Old 11-28-2012, 04:33 PM
Illiana Chapter Director

 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 12,320
Thanks: 5
Thanked 84 Times in 79 Posts
Feedback Score: 2 reviews
I wouldn't think you'd have numbers that good with any kind of leak.
Reply With Quote Quick reply to this message
  #5  
Old 11-28-2012, 05:02 PM
Premium Member
 

Join Date: Nov 2008
Location: Winder, GA
Posts: 454
Thanks: 17
Thanked 34 Times in 6 Posts
Feedback Score: 0 reviews
An otherwise normal running truck should be around 2750 @ 2000 RPM and achieve around 3900 by 3150 RPM. 560-580 at idle is normal. If you're only seeing 3070 PSI (assuming a reasonable RPM) then there's definitely a concern. First stop, ICP sensor. Check for oil seepage in the connector. If there is, it's definitely bad. If not, could still be bad and just reading low. Other possible causes, leaking O-rings at the injector, bad injector, weak HPOP, bad IPR. By the way, what was your IPR duty cycle at 3070 PSI?
Reply With Quote Quick reply to this message
  #6  
Old 11-28-2012, 05:11 PM
Super Moderator


 

Join Date: Mar 2008
Location: Abingdon, Md.
Posts: 11,965
Thanks: 3
Thanked 26 Times in 15 Posts
Feedback Score: 3 reviews
Hey Bill, I need to talk to you sometime soon. I hope to have my truck ready for another tuning session by Xmas and will be back down in NC again around the first of the year. It should be a whole different animal this time.

Mitch
Reply With Quote Quick reply to this message
  #7  
Old 11-28-2012, 05:24 PM
Member
 

Join Date: Sep 2012
Location: Azle,tx.
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks Power, thats what i am looking for. I did not know to check the IPR duty cycle. but I will get that done and post it back on here. the 3070psi was around 3000rpm. the truck runs good, and starts fine on the stock tune. no misses or stuttering. just noticed the ICP was pretty low at WOT.
Reply With Quote Quick reply to this message
  #8  
Old 11-28-2012, 05:26 PM
Member
 

Join Date: Sep 2012
Location: Azle,tx.
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
By the way where is the ICP sensor located? Is it the one on the pass valve cover?
Reply With Quote Quick reply to this message
  #9  
Old 11-28-2012, 05:59 PM
Making ported intakes

 

Join Date: Dec 2010
Location: Anaheim, Ca
Posts: 1,545
Thanks: 104
Thanked 50 Times in 44 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by Turbo6.0 View Post
By the way where is the ICP sensor located? Is it the one on the pass valve cover?
Yup pass side valve cover
Reply With Quote Quick reply to this message
  #10  
Old 11-28-2012, 06:06 PM
Member
 

Join Date: Sep 2012
Location: Azle,tx.
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks Odawg.
Ok, here is what I learned on a test drive. The ICP is around 1500psi at 2000rpm. it never goes above 3100psi at 3150rpm. It will flash to 3725psi,en you stab the throttle, but if you stay in it. It will settle right back to 3070psi. the TS 5015 does not give a IPR duty cycl monitor option.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:08 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors