airdog 2 and amps!! please read!! - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 10-22-2012, 04:43 PM Thread Starter
Powerstroke Techie


 
JUGERNAUT's Avatar
 
Join Date: Jan 2011
Location: UPPER SALFORD PA
Posts: 2,042
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 81
Thanked 68 Times in 37 Posts
Feedback Score: 13 reviews
airdog 2 and amps!! please read!!

I dont mean to beat a dead horse but i really want to get some data guys! i would love it people could read the amps on there airdogs so the guys that are having no issues can compare there amps to the ones having the issues. the reason is this, the ones with high amps may be from a certian run of pumps that we could make the manufacture aware of. or we may even find that the trucks having problems may have bad frame or body grounds that cause this issue. PLEASE HELP IF YA CAN!!


2001 to 2015 SENIOR MASTER TECHNICIAN
BEEN WITH FORD 27 YEARS:
PROUD NAVY VET= ANTI SUBMARINE WARFARE
A/C ASW A/W WINGS

2003 F250 AND I HATE IT. IT ROBS ME BEFORE I GET TO BANK!
JUGERNAUT is offline  
post #2 of 4 Old 10-22-2012, 04:59 PM
Marine Raiders>Seals



 
najaf4life's Avatar
 
Join Date: Dec 2006
Location: Solsberry, IN
Posts: 7,120
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 4
Thanked 66 Times in 49 Posts
Feedback Score: 0 reviews
I have not looked at mine.. Guess I can do this soon... you just want amp draw at idel? and what psi?

I planned on rewiring everything in the next month or two when I do studs, injectors and turbo

RYAN
03 Excursion 6.0L

BPD,WPE & other odds and ends
najaf4life is offline  
post #3 of 4 Old 10-22-2012, 05:49 PM
Compression Ignition Addict
 
Join Date: May 2008
Location: Easton, CT
Posts: 670
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
If you are using the airdog harness most likely you took positive and ground from the batt or alternator if you followed the install sheet. If off the batt I see no way off having a bad body ground effecting the pump. If the batt terminals are corroded to hell then maybe a bad connection. I guess it would be good to get amp readings and also how it's wired.
mikeproc is offline  
post #4 of 4 Old 10-22-2012, 05:54 PM Thread Starter
Powerstroke Techie


 
JUGERNAUT's Avatar
 
Join Date: Jan 2011
Location: UPPER SALFORD PA
Posts: 2,042
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 81
Thanked 68 Times in 37 Posts
Feedback Score: 13 reviews
yes at idle and your pressure


2001 to 2015 SENIOR MASTER TECHNICIAN
BEEN WITH FORD 27 YEARS:
PROUD NAVY VET= ANTI SUBMARINE WARFARE
A/C ASW A/W WINGS

2003 F250 AND I HATE IT. IT ROBS ME BEFORE I GET TO BANK!
JUGERNAUT is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome