truck started acting up...TPS sensor maybe? - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-23-2012, 10:03 AM
Compression Ignition Addict
 

Join Date: Apr 2011
Location: springville NY
Posts: 2,275
Thanks: 20
Thanked 31 Times in 26 Posts
Feedback Score: 1 reviews
truck started acting up...TPS sensor maybe?

Damn, truck started acting up alot today. Put it in drive and start to accelerate...then all of a sudden it'd go flat on it's face. When it does the glow plug light would flicker like once or twice then go out every time this happened. I also noticed that on my edge insight the throttle postition setting would stay on the certain % when this would happen. It just so happened that the last time it did this the pedal postition was at 25% and stayed there even in park idling. Makes me think the TPS sensor is taking a dump. Anyone got any thoughts
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-23-2012, 04:25 PM
Compression Ignition Addict
 

Join Date: Apr 2011
Location: springville NY
Posts: 2,275
Thanks: 20
Thanked 31 Times in 26 Posts
Feedback Score: 1 reviews
Well it's not the APP(accelerator pedal position) sensor. Swapped the one out of my cousins truck and it didn't change anything. However my truck started stalling now also. But i found out that once it got up to temp it stopped doing it...so i'm at a loss right now. i'm not sure i actually feel safe driving it because it actually stalled on me while driving. It did throw a code...P2614 camshaft position signal output circuit low. But the truck will automaticlly throw that code when it stalls so i'm not 100% sure that it can be the camshaft sensor
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:17 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors