Got my FICM back today - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-21-2012, 09:45 AM
Powerstroke.org Fanatic
 

Join Date: Sep 2011
Location: centeral kansas
Posts: 98
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Got my FICM back today

Well I sent the ficm off last week and recieved it today, cant wait to instal it. Ficmrepair.com did the work. Had the atlas 40 put on as well. Now when i took it out all four rubber bushing were gone/missing from the previous owner. I do feel it is important to have them ther to eat some of the vibration. I have all kinds of rubber hose avaliable so i plan on just sizing some to fit just like the factory bushings. That should work just fine right? At least it will be better than nothing.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-21-2012, 10:03 AM
Compression Ignition Addict
 

Join Date: Feb 2008
Posts: 8,436
Thanks: 72
Thanked 215 Times in 203 Posts
Feedback Score: 0 reviews
I wouldn't

ford parts dept is open on Saturday near ME I would Be wanting to get the OEM isolators

If you just can't wait I would call the hose temporary unless your confident it Mimics the OEM qualities
Reply With Quote Quick reply to this message
  #3  
Old 07-21-2012, 10:15 AM
Compression Ignition Addict
 

Join Date: Feb 2008
Posts: 8,436
Thanks: 72
Thanked 215 Times in 203 Posts
Feedback Score: 0 reviews
just so you know what your looking for see page 4

they changed the location of the isolators so you may still have them on your lower bracket VS FICM

http://www.fordtechservice.dealercon...FICM_Guide.pdf
Reply With Quote Quick reply to this message
  #4  
Old 07-21-2012, 04:02 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
You are not going to like this, I had one missing on mine, there is am upper and lower bushing piece. It was crazy expensive from my "local" dealer. I forgot how much, something like 13 bucks for one plus a pack of four ficm bolts. I only needed one bolt but it comes with four. With that said, I think they are absolutely necessary. Tousley ford can hook you up for cheap. I had the part numbers, but can't find them now.

Sent from my SCH-I500
Reply With Quote Quick reply to this message
  #5  
Old 07-21-2012, 04:25 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Quote:
Originally Posted by ZMANN View Post
just so you know what your looking for see page 4

they changed the location of the isolators so you may still have them on your lower bracket VS FICM

http://www.fordtechservice.dealercon...FICM_Guide.pdf
Zmann, good info, but I think that is misleading. My early 04my has rubber bushings on the bracket and ficm. I don't know about the later years. In the picture it shows bushings on the ficm for early years then it shows bushings on the bracket for later years. It's hard to see if there are bushings on the ficm for later years because the arrows are in the way.

Sent from my SCH-I500
Reply With Quote Quick reply to this message
  #6  
Old 07-21-2012, 07:04 PM
Premium Member
 

Join Date: Mar 2010
Location: Stockbridge, Mi.
Posts: 756
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 7 reviews
The later years '05-'07 (and maybe '04.5) don't come with rubber bushings at the FICM
Reply With Quote Quick reply to this message
  #7  
Old 07-21-2012, 07:19 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Quote:
Originally Posted by Arctic Fox View Post
The later years '05-'07 (and maybe '04.5) don't come with rubber bushings at the FICM
Interesting, thanks.

Sent from my SCH-I500
Reply With Quote Quick reply to this message
  #8  
Old 07-21-2012, 09:59 PM
Powerstroke.org Fanatic
 

Join Date: Sep 2011
Location: centeral kansas
Posts: 98
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Yep ive got the lower ones. I thought ther were installed in the large holes on the ficm. Well i got it installed, and i crank, but no start. The only electrical things i unpluged were the 3 plugs themselves. Yes all 3 clicked. Just one single click each. Tomorrow morning i will reinstal it. Maby i bent a pin.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:05 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors