Poor MPGs after AFE Intake/ Continue with SRL - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-04-2012, 11:54 AM
Member
 

Join Date: Dec 2011
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Poor MPGs after AFE Intake/ Continue with SRL

About 2 weeks ago I put an AFE Stage II Pro Gaurd. The one with the battery in the air box. Running about 65 mph i would average around 17-18. After putting the intake on I dropped to about 15.5. At that time I was running the canned performance tune on my SCT. I just downloaded Matts SRL tune early this week got 15 in city driving near Chicago. Came home to Indy for the weekend and going 65 I only got 16. Hardly any wind. I did just adjust my tire revs per mile and the rear end setting was set at stock. So I did enter on the 373 one. Help me out if you can. Also I just put on a Sinister Coolant Filter. Wanting to do the Amsoil By pass filter in the next few weeks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-04-2012, 12:17 PM
BACKYARDIGAN


 

Join Date: Feb 2010
Location: Huntington, WV
Posts: 4,425
Thanks: 26
Thanked 70 Times in 46 Posts
Feedback Score: 2 reviews
try installing the stock filter back on and see if it is indeed the filter setup. also since you were running the canned performance tune, you should go back to that for the verification test.
Reply With Quote Quick reply to this message
  #3  
Old 03-04-2012, 12:30 PM
Compression Ignition Addict
 

Join Date: Apr 2010
Posts: 2,039
Thanks: 0
Thanked 5 Times in 4 Posts
Feedback Score: 0 reviews
You do know how many factors there are to MPG right? Like wind speed, temperature, humidity, elevation....
Reply With Quote Quick reply to this message
  #4  
Old 03-04-2012, 01:17 PM
Member
 

Join Date: Dec 2011
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have to make the trip every weekend. I adjusted my tirerevs per mile and my rear end. I'll see if that could change the mileage on the odometer. If it rolls the same I will go back to stock filter. Everyone I've talked to that has the same AFE set up has no problems but 1-2 gains
Reply With Quote Quick reply to this message
  #5  
Old 03-04-2012, 01:24 PM
BACKYARDIGAN


 

Join Date: Feb 2010
Location: Huntington, WV
Posts: 4,425
Thanks: 26
Thanked 70 Times in 46 Posts
Feedback Score: 2 reviews
yep that is what I have heard as well.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:37 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors