Problem with CTS - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 12-10-2011, 11:35 AM Thread Starter
Powerstroke.org Fanatic
 
07lariat's Avatar
 
Join Date: Nov 2008
Posts: 96
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Problem with CTS

I have a CTS Insight with the expandable EGT sensor. Everything has been great with it as a monitor until recently. Twice now, I have gone out to start the truck when the temp has been just below freezing, and found that the EGT sensor was no longer recognized by the Insight. Once I had to unplug it and after plugging it back in the EGT was back. The last time I has the problem, the EGT came back after a couple of ignition cycles. Has anyone else had similar issues? If so, whats going on and how do I fix it?

2007 Lariat FX4 Crew Cab
275/75/18 Goodyear Duratracs
9000 lb Warn Front Hitch
08 Aluminum rear diff cover
HID headlights
Edge CTS Insight
SCT SF3 flash tuner
Blue spring mod
6.4 banjo bolts
high idle mod
07lariat is offline  
post #2 of 5 Old 12-10-2011, 11:40 AM
Premium Member
 
sargar's Avatar
 
Join Date: Jul 2011
Location: Monroe, Georgia
Posts: 3,873
Thanks: 1
Thanked 23 Times in 22 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Then same but different. Edge has on their monthly newsletter a note about the Insight not working in extreme hot/cold temps. They claim normal operation. I have a friend with a CTS newer than mine that checked out yesterday. It would only beep and had a blank screen. It got hooked up to the computer and had a software/firmware update and works correctly now. Maybe check to see it there is an update available for yours. I assume that you have made sure the connection for the EGT sensor is good.

Tuned, Deleted, Filtered, Monitored...all the usual stuff.
sargar is offline  
post #3 of 5 Old 12-10-2011, 06:26 PM
Compression Ignition Addict
 
Join Date: Sep 2011
Location: Newellton, LA
Posts: 1,249
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
I had kinda of a similar problem with mine also. I was playing in the mud and of course EOC, ECT, & trans temp come up, still well within acceptable range. My Insight registered all the higher temps but they never come back down they where just frozen at the highest temp that it read. I knew that the temps had to be lower after playing in mud so I unplugged it and the temps read right after that. This was only a week ago and the day before I checked for updates and it was up to date. Has anyone else had this problem?

2012 F250 Lariat CCSB FX4, Gooseneck and 5th wheel prep package, H&S Minimaxx, 5" AFE SS straight pipe, EGR delete with factory EGT sensor, 35" Toyo MT's on stock rims, and Bilstein 5160 shocks.
thomaslord84 is offline  
post #4 of 5 Old 12-11-2011, 03:25 AM
Premium Member
 
custom4584's Avatar
 
Join Date: Apr 2006
Location: Hagerstown, MD
Posts: 279
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
Mine isn't working at all in cold temperatures. I called edge the other day and it seems to be a software issue. They knew exactly what I was talking about and told me they sent my fusion account an update. I haven't done so yet but the next time I plug it in to my computer it will update it and resolve the issue. Call them and get the updates. Their customer service was awesome!


Sent from my Autoguide iPhone app

03 F-250 CC short box 6.0 psd auto.
6.4 banjos
Edge insight CTS
Egr delete
custom4584 is offline  
post #5 of 5 Old 12-11-2011, 04:37 AM Thread Starter
Powerstroke.org Fanatic
 
07lariat's Avatar
 
Join Date: Nov 2008
Posts: 96
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I tried the automatic update last night but I guess I have the latest already. I'll try to call them about the specific update you mentioned. Thanks

2007 Lariat FX4 Crew Cab
275/75/18 Goodyear Duratracs
9000 lb Warn Front Hitch
08 Aluminum rear diff cover
HID headlights
Edge CTS Insight
SCT SF3 flash tuner
Blue spring mod
6.4 banjo bolts
high idle mod
07lariat is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome