airdog /starting problem - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-10-2011, 01:03 PM
Member
 

Join Date: Feb 2010
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
airdog /starting problem

I've been having trouble getting my truck to start after it's been sitting. Takes 3 or 4 10-15 second cranks for it to start then it starts real rough with a low idle. I have a new 58v FICM from quick tricks so I'm pretty sure that's not it. I realized today that my Airdog is leaking between the pump and the plate. Sounds like it's sucking air when the pump first starts then starts leaking fuel. Then continues to leak even after the truck is shut off. Could this be causing my starting problems? Thinking that it's bleading off pressure and loosing it's prime.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-10-2011, 02:05 PM
Compression Ignition Addict
 

Join Date: Dec 2010
Location: Kerrville
Posts: 863
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
i doubt it. could be but even at that there would still be fuel in the rails to start the truck atleast. sounds like a bad gasket on the pump which you can call airdog and they can get you one pretty quickly. not sure what could cause it need more info
Reply With Quote Quick reply to this message
  #3  
Old 11-10-2011, 03:11 PM
BACKYARDIGAN


 

Join Date: Feb 2010
Location: Huntington, WV
Posts: 4,697
Thanks: 29
Thanked 93 Times in 66 Posts
Feedback Score: 2 reviews
Yea contact Airdog ASAP.
Reply With Quote Quick reply to this message
  #4  
Old 11-10-2011, 03:26 PM
Compression Ignition Addict
 

Join Date: Aug 2011
Posts: 351
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Contact Airdog, definitely wouldn't be the first time we have seen a similar issue...
Reply With Quote Quick reply to this message
  #5  
Old 11-11-2011, 05:42 AM
Member
 

Join Date: Feb 2010
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I called Airdog, they said the pump shaft seal was bad. I have a new pump on the way. If that doesn't solve the problem I guess I will have to put it in the shop. Very hard to start and when it does it chugs at a very low idle until it finally catches. Sometimes it wont start without me holding the accelerator to the floor.
Reply With Quote Quick reply to this message
  #6  
Old 11-11-2011, 07:54 AM
Compression Ignition Addict
 

Join Date: Dec 2010
Location: Kerrville
Posts: 863
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
i had a buddy of mines truck do that once couldnt figure it out. turned out to be a bad regulator by the fuel bowl so maybe that is your problem and by that i mean the airdog
Reply With Quote Quick reply to this message
  #7  
Old 11-18-2011, 11:31 AM
Member
 

Join Date: Feb 2010
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Put the new pump on and it's good as gold. Starts right up. Thanks for chiming in guys!
Reply With Quote Quick reply to this message
  #8  
Old 11-18-2011, 01:36 PM
BACKYARDIGAN


 

Join Date: Feb 2010
Location: Huntington, WV
Posts: 4,697
Thanks: 29
Thanked 93 Times in 66 Posts
Feedback Score: 2 reviews
That is GREAT man and it sounds like Airdog, really came through for you. Did they require you to send your pump in first? It doesnt sound like they did.
Reply With Quote Quick reply to this message
  #9  
Old 11-19-2011, 05:21 AM
Member
 

Join Date: Feb 2010
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Kinda got the shaft on that one. They say I didn't get my warranty card to them in time so they didn't cover it. $165 but they got it to me quick. The new pump is registered. Live and learn!
Reply With Quote Quick reply to this message
  #10  
Old 11-19-2011, 05:29 AM
BACKYARDIGAN


 

Join Date: Feb 2010
Location: Huntington, WV
Posts: 4,697
Thanks: 29
Thanked 93 Times in 66 Posts
Feedback Score: 2 reviews
See that is the stuff that bothers me. I am convinced that the airdog is probably the overall best way to go as far as an aftermarket pump goes but it just seems that too many folks get stuck somewhere and yea they have a "lifetime warranty" that IMO is a POS. Usually stuff that is warrantied for life very rarely fails. JMO. Eitherway glad to hear that the new pump is working great for you now and hopefully it keeps up.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:55 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors