Where did my power go - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-25-2011, 10:18 AM
Powerstroke.org Fanatic
 

Join Date: Sep 2009
Location: Inglis,fl
Posts: 143
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Where did my power go

I have been running idp ex street for a while now. My truck seems down on power. I have no puking so I don't think it's the head gaskets. I changed the fuel filters.
When I 1st put my edge insight on it ran a 14.8 1/4. Today it would only run a 16.4. What should I check out. I have no codes
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-25-2011, 10:35 AM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: Roanoke, VA
Posts: 1,212
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Give some more info on the truck please. Year miles mods etc....
Reply With Quote Quick reply to this message
  #3  
Old 01-25-2011, 10:45 AM
Powerstroke.org Fanatic
 

Join Date: Sep 2009
Location: Inglis,fl
Posts: 143
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sorry. It's a 2004 sb cc 4x4 auto trans 141000. Edge insight, sct sf3 idp ex street. Stock exhaust with no muffler or cat. Egr delete. 8" lift 38x15.5r20 I think that's it.
Reply With Quote Quick reply to this message
  #4  
Old 01-25-2011, 11:03 AM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: Roanoke, VA
Posts: 1,212
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Pictures?

Does it ever have a hard time starting or crank for a long time before it fires?
Reply With Quote Quick reply to this message
  #5  
Old 01-25-2011, 11:22 AM
Powerstroke.org Fanatic
 

Join Date: Sep 2009
Location: Inglis,fl
Posts: 143
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No it starts right up. Even when cold. Some time when it below 40 it wil run real ruff for about 5 seconds then clears up.
I'm not sure how to post pics on here
Reply With Quote Quick reply to this message
  #6  
Old 01-25-2011, 11:28 AM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: Roanoke, VA
Posts: 1,212
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Do you have a PhotoBucket acct? you can copy the image code and put it in your reply.

The only thing i can think of right off hand would be your HPOP is dying Maybe someone else will chime in and suggest something not so harsh....
Reply With Quote Quick reply to this message
  #7  
Old 01-25-2011, 01:18 PM
Powerstroke.org Fanatic
 

Join Date: Sep 2009
Location: Inglis,fl
Posts: 143
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Been doing a Lil reading. Looks like it could be my hpop or ipr. I looked and I do have a oil leak on the back of the engine.
Reply With Quote Quick reply to this message
  #8  
Old 01-25-2011, 01:27 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: Roanoke, VA
Posts: 1,212
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'd Defintely check your IPR then that should be where your leak is coming from and the cause of your low power
Reply With Quote Quick reply to this message
  #9  
Old 01-25-2011, 01:43 PM
Emergency Services
 

Join Date: Dec 2006
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have a 2000 7.3l with close to the same problem. it has a ts chip and it seems to hav lack of power and leaks oil from back of engine. what is IPR?

Thank you
Reply With Quote Quick reply to this message
  #10  
Old 01-25-2011, 01:45 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: Roanoke, VA
Posts: 1,212
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Injection Pressure Regulator, I don't want to give you any advice though as im not as familiar with the 7.3 as i am the 6.0. Have you posted in the 7.3 Problems section?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:44 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors