bad injectors - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-15-2010, 03:50 PM
Powerstroke.org Rookie
 

Join Date: Aug 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bad injectors

my truck started throwing injectors one after another so i replaced all 8 with 155s a new fuel presure reg. and airdog. now my new injectors are starting to go one by one. change filters every other oil change too. anyone else have this issue before?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-15-2010, 04:20 PM
Lt. Negativity
 

Join Date: Jun 2007
Location: Stafford
Posts: 1,738
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
FICM check that. Need to know yr and model ? also who's injector ? Im guessing RCD ?
Reply With Quote Quick reply to this message
  #3  
Old 09-15-2010, 05:17 PM
Super Moderator


 

Join Date: Mar 2008
Location: Abingdon, Md.
Posts: 11,983
Thanks: 4
Thanked 31 Times in 16 Posts
Feedback Score: 3 reviews
Quote:
Originally Posted by RescueF250 View Post
FICM check that. Need to know yr and model ? also who's injector ? Im guessing RCD ?
Whatever gives you that idea Kevin?
Reply With Quote Quick reply to this message
  #4  
Old 09-16-2010, 04:44 AM
Lt. Negativity
 

Join Date: Jun 2007
Location: Stafford
Posts: 1,738
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Not too many folks make 155s and have problems
Reply With Quote Quick reply to this message
  #5  
Old 09-16-2010, 06:49 AM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: California
Posts: 4,260
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
How long have you been running the 155's?
Reply With Quote Quick reply to this message
  #6  
Old 09-16-2010, 08:50 AM
Super Moderator


 

Join Date: Mar 2008
Location: Abingdon, Md.
Posts: 11,983
Thanks: 4
Thanked 31 Times in 16 Posts
Feedback Score: 3 reviews
Quote:
Originally Posted by RescueF250 View Post
Not too many folks make 155s and have problems
Sorry Kevin, I was being facetious. Doesn't seem to matter what size they are if RCD made them.
Reply With Quote Quick reply to this message
  #7  
Old 09-16-2010, 03:51 PM
Powerstroke.org Rookie
 

Join Date: Aug 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
my bad guys they are 150s. pensacola diesel built them. same problem i had with my stock sticks, breaks up really bad until truck is hot then it runs fine. trucks an 04 f-250 and still runs my factory lift pump with my airdog. any chance that could be getting weak?
Reply With Quote Quick reply to this message
  #8  
Old 09-17-2010, 12:13 PM
Super Moderator


 

Join Date: Mar 2008
Location: Abingdon, Md.
Posts: 11,983
Thanks: 4
Thanked 31 Times in 16 Posts
Feedback Score: 3 reviews
Check your FICM voltage while cranking it or revving it. It should be 48v. If not your FICM is going bad. That's what mine did when my FICM was headed south and I initially thought it was injectors too.

I see Kevin already suggested that. Have you done it yet?
Reply With Quote Quick reply to this message
  #9  
Old 09-17-2010, 02:39 PM
Powerstroke.org Rookie
 

Join Date: Aug 2010
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no im gonna check it this weekend cause id like to get my FICM tuned by innovative but i wanna see if i need a new one first.
Reply With Quote Quick reply to this message
  #10  
Old 09-17-2010, 03:36 PM
Lt. Negativity
 

Join Date: Jun 2007
Location: Stafford
Posts: 1,738
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
GET THOSE INJECTORS OUT OF THERE !!!!! Just had to put in a long block for a customer, both cylinders that had those injectors in them had melted pistons.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:25 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors