Fass Install Question - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 08-12-2010, 05:00 PM Thread Starter
2006smokin'6.0's Avatar
Join Date: Dec 2009
Location: Shorline, in CT
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fass Install Question

I'm sorry if this has been posted already, I didn't see anything. I just bought a FASS Titanium Series pump for my 06' 6.0. I was looking to see if anyone that has done an install has any hints or ideas that might make the process easier.
Thanks in advance for any help

2006 F-350 EC SB 4X4 Lariat
S&B Intake
SCT Livewire w/tunes by IDP/BTS
ARP Studs
EGR Delete
4" Stainless MBRP Dual 5" Tips No Cat
FASS Titanium
High Idle
3" Leveling Kit
B&W Gooseneck
Custom Whelen Lighting

~Dodge is just a shipping crate for Cummins~
2006smokin'6.0 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome