What happened to my Insight - Ford Powerstroke Diesel Forum

6.0L Performance Parts Discussion What has or has not worked for you?

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 05-02-2010, 05:19 PM Thread Starter
Compression Ignition Addict
 
Join Date: Nov 2006
Posts: 164
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
What happened to my Insight

I have had the Edge Insight for a few months now.....

It has worked as it is supposed to during this time. Yesterday the insight would light up but the screen itself was faded black.....as it was working but the display was blank. I figured I would deal with it later.....this evening I walked by the truck only to see the insight still working. Normally it shuts off after the key is turned off and then waits a few seconds. I do not know what the deal with it is. I did use the SCT to put the truck back to stock and still the same thing. I then put the program in and it made no difference. I am going to call Edge tomorrow just wanted to see if any one has ran across this.

I also plugged the insight into my laptop......same deal just this time the color is red instead of the blueish green color.....

2006 F250 6.0 Crew Cab King Ranch 4x4
SCT XCAL2
Edge Insight
Kitty ran away
jayman69 is offline  
post #2 of 2 Old 01-25-2011, 06:14 PM
Powerstroke.org Fanatic
 
Join Date: Jan 2008
Location: Bradenton,Fl
Posts: 141
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by jayman69 View Post
I have had the Edge Insight for a few months now.....

It has worked as it is supposed to during this time. Yesterday the insight would light up but the screen itself was faded black.....as it was working but the display was blank. I figured I would deal with it later.....this evening I walked by the truck only to see the insight still working. Normally it shuts off after the key is turned off and then waits a few seconds. I do not know what the deal with it is. I did use the SCT to put the truck back to stock and still the same thing. I then put the program in and it made no difference. I am going to call Edge tomorrow just wanted to see if any one has ran across this.

I also plugged the insight into my laptop......same deal just this time the color is red instead of the blueish green color.....
I have the same problem with my insight recently where it will just be blank with no readings when I turn the truck on. When I turn it off, it stays on until I unplug it. It says I have the latest update on my computer. did you ever get an answer or a fix for why yours was doing this. Thanks.

Trent

2006 F-250. 5" lift, ICON 2.0 shocks, 315/70/17 Goodyear Duratracs, 17" Weld Wheels, MagHytec cover, 4" Banks Exhaust, AFE Stage 2, Banks High Ram intake, 6000K HID headlights and fog lights, Recon lights,Fumoto Oil Drain , SCT tuned (IDP, Gearhead, Quicktricks), Edge CTS Insight,ARP studs,EGR delete, Powermax turbo w MTW billet wheel, NUC Oil Bypass filter and Dieselsite Coolant Filter,Ford Upgraded Fuel Spring
GAstroker2006 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome