can you use aftermarket injectors with a WVO system? - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 03-16-2010, 04:00 PM Thread Starter
Compression Ignition Addict
 
rodmodder's Avatar
 
Join Date: Oct 2009
Location: Walworth County
Posts: 165
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
can you use aftermarket injectors with a WVO system?

Just curious...



2005 F-250 4x4 CCSB
Straight piped, deleted, leveled and rockin 305's.
rodmodder is offline  
post #2 of 4 Old 03-16-2010, 06:16 PM
Super Moderator


 
PGreenSVT's Avatar
 
Join Date: Mar 2008
Location: Abingdon, Md.
Posts: 11,991
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 4
Thanked 46 Times in 18 Posts
Feedback Score: 3 reviews
An injector is an injector. Same rules apply as to the stock injector. Well filtered and heated to at least 160* before the injector.
PGreenSVT is offline  
post #3 of 4 Old 03-16-2010, 09:29 PM
Compression Ignition Addict
 
mdub707's Avatar
 
Join Date: Feb 2008
Location: Central NY
Posts: 1,822
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Most will tell you over 200* is actually preferred. 160* is more of a base line, the hotter the better though (to a certain extent) 6.0's are a great motor to run WVO in because it gets heated in the head before being injected.

Larger injectors will be fine though. Like PGreenSVT said, it needs to be filtered well and heated to run.





DamnKids Motorsports
2006 F-250 6.0 4x4
Innovative Diesel Tuning 466/772 7/19/08
VEGISTROKED
mdub707 is offline  
post #4 of 4 Old 03-17-2010, 08:21 AM
Super Moderator


 
PGreenSVT's Avatar
 
Join Date: Mar 2008
Location: Abingdon, Md.
Posts: 11,991
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 4
Thanked 46 Times in 18 Posts
Feedback Score: 3 reviews
Yeah I was using 160 as a temp to turn the WVO on. By the time it gets to the injector it is nice and hot.
PGreenSVT is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome