SCT X3 start up problems - Ford Powerstroke Diesel Forum
6.0L Performance Parts Discussion What has or has not worked for you?

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-21-2009, 05:43 PM Thread Starter
Compression Ignition Addict
yosh30's Avatar
Join Date: Sep 2008
Posts: 556
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
SCT X3 start up problems

So this problem is bugging the hell out of me, so i just moved to montana and after the long drive my truck was acting kind of odd, turbo wasnt spooling as quick as usual and i was just puffin alot of smoke(black) i plugged my X3 in to moniter a few things and everything seemed to be pretty good. So i unplug it and go about my business, well i went to change the tune the other day and the damn thing wont turn on at all, when i plug it into my computer it turns right on but not when i plug it into the ODB11 port..anyone ever have this happen? would it be the port or the cord on the X3? hope someone can turn me in the right direction.

2003 FORD F350
6" Fabtech lift
37" FCII on 17" weld racing wheels
SCT X3 w/ Innovative tunes
Speedhut revolution gauges
5 Inch MBRP exhaust w/ 7inch tip
yosh30 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome