Climate Control No Power/Dead - Ford Powerstroke Diesel Forum
6.0L Ford Excursion Discussion This forum is for topics relating to the excursion only.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-08-2008, 01:43 PM
Powerstroke.org Rookie
 

Join Date: Mar 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Climate Control No Power/Dead

I started my 2003 X this afternoon and climate control screen was blank and nothing works. Fuse is okay. Is there anything else I can check? Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-08-2008, 05:34 PM
Premium Member
 

Join Date: Feb 2007
Location: Wisconsin
Posts: 1,366
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
That happened to my truck once, but i shut it off, and started it and its worked ever since. Is yours not working all the time?
Reply With Quote Quick reply to this message
  #3  
Old 07-08-2008, 05:47 PM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,242
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
there have been a few issues with the actual temp controller taking a dump, hard to say really without digging in
Reply With Quote Quick reply to this message
  #4  
Old 07-08-2008, 06:27 PM
Powerstroke.org Rookie
 

Join Date: Mar 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
On another board I was told to cycle the headlights on and off. It worked immediately after i did it.
Reply With Quote Quick reply to this message
  #5  
Old 07-08-2008, 06:31 PM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,242
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
thats a new one on me , you think just the light dimmer in the controller had just gotten stuck
Reply With Quote Quick reply to this message
  #6  
Old 07-08-2008, 06:59 PM
Powerstroke.org Rookie
 

Join Date: Mar 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
must be what happens, a relay sticking.
Reply With Quote Quick reply to this message
  #7  
Old 07-10-2008, 01:12 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Las Vegas,NV
Posts: 259
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
this is a fairly common problem on Excursions(maybe trucks too) that have the auto headlight feature and EATC..it doesn't happen often and the "cycle headlight switch" trick clears it every time..

i know back in the day someone had figured exactly why the relay gets hung up, but i've forgotten now..regardless, nothing is really broken and it's just a little quirk to have to deal with..
Reply With Quote Quick reply to this message
  #8  
Old 07-11-2008, 10:38 AM
Compression Ignition Addict
 

Join Date: Mar 2007
Location: Arlington, TX
Posts: 798
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Happened to me too. Never happened since.
Reply With Quote Quick reply to this message
  #9  
Old 07-15-2008, 07:20 AM
Powerstroke.org Fanatic
 

Join Date: Sep 2006
Location: Lafayette, Louisiana
Posts: 133
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I've had the same issue intermittently. I've never heard the "cycle headlight switch" trick. I'll have to try it.
Thanks!
Reply With Quote Quick reply to this message
  #10  
Old 07-27-2008, 05:01 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2008
Posts: 126
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
mine did it twice..1st time it came on 2 days later on it's own. the last time was last weekend and i thought if i turned the lights on maybe it would power up since there were no lights..and it has been working since.and i thought of it on my own..wow LOL not bad for a dumbazz lol
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:09 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors