Surges at idle sometimes?? - Ford Powerstroke Diesel Forum
6.0L Ford Excursion Discussion This forum is for topics relating to the excursion only.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-14-2008, 09:08 PM
Member
 

Join Date: Dec 2007
Location: Hazleton PA
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Surges at idle sometimes??

Well this one has me stumped, I have a '03 X 6.0 and when ever it feels the urge to it will surge just a idle. This only occures after it's warmed up and it may do this all day long or it won't do it for days . No codes or service engine light, hooked it to the scanner and ran all the tests and all ok.
It's been doing this for months and it doesn't seem to hurt anything but it drives me nuts because I know it's not right. Any suggestions
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-14-2008, 09:44 PM
Compression Ignition Addict
 

Join Date: May 2007
Location: America
Posts: 6,783
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
ICP sensor. Brothers 03 6.0 got replaced and his surging idle went away.
Reply With Quote Quick reply to this message
  #3  
Old 03-14-2008, 09:50 PM
PIPE HITTER
 

Join Date: Mar 2006
Location: Republic of Texas
Posts: 1,472
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by 2005F250 View Post
ICP sensor. Brothers 03 6.0 got replaced and his surging idle went away.
My suggestion as well....
Reply With Quote Quick reply to this message
  #4  
Old 03-15-2008, 06:24 PM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Location: Sparrows Point Md
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the post my 03' is doing the same thing.
Reply With Quote Quick reply to this message
  #5  
Old 03-15-2008, 09:14 PM
Member
 

Join Date: Dec 2007
Location: Hazleton PA
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the reply, I'll get one next week and post the result
Reply With Quote Quick reply to this message
  #6  
Old 05-22-2008, 12:45 PM
Powerstroke.org Rookie
 

Join Date: May 2008
Location: Troy, MI
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by viper5 View Post
Thanks for the reply, I'll get one next week and post the result

So did this fix your problem
Reply With Quote Quick reply to this message
  #7  
Old 05-22-2008, 05:22 PM
Member
 

Join Date: Dec 2007
Location: Hazleton PA
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No the ICP sensor didn't fix the problem, but shortly after I changed the ICP sensor(2 weeks) it started to miss and I changed 2 injectors to correct that problem and it hasn't surged since. I have heard that most of the time it is the ICP sensor that causes the surging problem
Reply With Quote Quick reply to this message
  #8  
Old 05-23-2008, 07:00 AM
Powerstroke.org Rookie
 

Join Date: May 2008
Location: Troy, MI
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How did you determine which ones to replace? Did you get diagnostic codes? My truck idles rough at times after it's warmed up and if the AC is on. It feels like it wants to stall. Sometimes it doesn't do it at all.
Reply With Quote Quick reply to this message
  #9  
Old 05-23-2008, 07:49 AM
Member
 

Join Date: Dec 2007
Location: Hazleton PA
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
First I did a injector buzz test which it passed, then I did a cylinder contribution test and found #1 & 5 were not fireing
Reply With Quote Quick reply to this message
  #10  
Old 05-27-2008, 07:38 AM
Powerstroke.org Rookie
 

Join Date: May 2008
Location: Troy, MI
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Did you have these tests run at a dealership? I just got my OASIS report and noticed I have not had any of the latest flashes. I'll try that first and see how it goes.

Thanks for the info and help.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:21 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors