04 hard start even in warm temp. - Ford Powerstroke Diesel Forum
6.0L Ford Excursion Discussion This forum is for topics relating to the excursion only.

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 01-25-2013, 01:56 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
04 hard start even in warm temp.

I have an 04 4X4 excursion. Hard to start cold no matter what outside temp. If I plug in block heater at night it starts right up. I am thinking glow plugs, but it is even hard to start in 90 degree temps. After running for 15 min or so restart is easy unless sits for 5 or 6 hours.
Thanks
GreenMachine2004 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 01-25-2013, 01:59 PM
PROUD AMERICAN!!!




 
Rattlesnake18's Avatar
 
Join Date: Nov 2009
Posts: 20,378
Thanks: 194
Thanked 562 Times in 479 Posts
Mentioned: 64 Post(s)
Quoted: 732 Post(s)
Feedback Score: 6 reviews
Have you tested your FICM? Mine had similar issues and it ended up being the FICM.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2004 F250 CC Lariat 4x4

BPD FICM, BPD billet water pump, BPD VK688 oil cooler kit, S&B CAI, MTW stage 2, TSD tunes, Auto Meter gauges, Edge CTS, Sinister coolant filter, Blue spring, 6.4 banjo bolts, Straight piped w/ 6" single mitre stack, Pro Comp leveling kit, 05-07 HD headlights, Fumoto block drain valves, ELC, High idle mod

Quote:
Originally Posted by djmaguire View Post
I'm guessing that you didn't lose nearly as much as it appeared. Spills are like that. The last beer that I spilled was like a million ounces.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Rattlesnake18 is offline  
post #3 of 3 Old 01-25-2013, 03:47 PM
Compression Ignition Addict
 
Join Date: Sep 2012
Location: Sparks, NV
Posts: 231
Thanks: 4
Thanked 6 Times in 6 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Have you read this yet:

No start issue? Look here.

If not, that's where I would start. Also, do you have some sort of monitor on it to read some parameters?
67rstbkt is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome