Trouble starting - Ford Powerstroke Diesel Forum
6.0L Ford Excursion Discussion This forum is for topics relating to the excursion only.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-08-2011, 05:20 AM
Premium Member
 

Join Date: Nov 2010
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Trouble starting

Having a bit of trouble trying to get my truck started after its been ran for a while. Scanned it with my tuner and it had P2290 which is injector pressure to low. so idk what that would even be on this thing.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-08-2011, 08:52 AM
Emergency Services

 

Join Date: Apr 2011
Location: Geraldton
Posts: 731
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Well, I'm not an expert, I'm a rookie who's trying to learn but I'll try to help. The more info you can supply the better and more accurate the responses will be. What is the truck doing or not doing, hot/cold, all the time, is it modded, what are you monitoring it's vitals with, what did you pull the codes with? The more background the better the help will be.

"Injector pressure low" points to a high pressure oil leak. The injectors need high pressure oil to fire, when the truck is hot the oil is "thinner" and the high pressure oil system has a harder time making enough pressure if there's a small leak. When the oil is cold it's easier to build pressure so you don't have any trouble starting.

Here's some reading and trouble shooting info...
Troublrshooting a no start condition

You'll have better luck searching in Google instead of the forum search and the other 6.0 folders get a lot more trafic than the Excursion forum does.

Good luck!
Reply With Quote Quick reply to this message
  #3  
Old 09-08-2011, 09:05 AM
Premium Member
 

Join Date: Oct 2010
Posts: 1,865
Thanks: 0
Thanked 12 Times in 11 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by EX2004 View Post
Having a bit of trouble trying to get my truck started after its been ran for a while. Scanned it with my tuner and it had P2290 which is injector pressure to low. so idk what that would even be on this thing.
Yep high pressure oil leak problem. Could be a bad pump on an 04, but not likely. High pressure oil leaks are the hardest thing to diagnose so without the proper scan tools and specialty tools it will be tough.
Reply With Quote Quick reply to this message
  #4  
Old 09-08-2011, 09:08 AM
Premium Member
 

Join Date: Oct 2010
Posts: 1,865
Thanks: 0
Thanked 12 Times in 11 Posts
Feedback Score: 0 reviews
Not to hijak but Fisher, hows the truck been running? I know you did a lot of work and was just curious? Also did your 2005 Excursion have the STC fitting that had to be replaced? I heard somewhere that the 05 Ex had an 04 motor...
Reply With Quote Quick reply to this message
  #5  
Old 09-08-2011, 10:16 AM
Premium Member
 

Join Date: Nov 2010
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks fisher. I will have to have my deisel tech take a look at it. Just wanted an idea of what was happening. It only does it after the truck is warm. Runs like a bad a$$ after its started though. I do LOVE my 6.0 Ex.
Reply With Quote Quick reply to this message
  #6  
Old 09-08-2011, 10:18 AM
Premium Member
 

Join Date: Nov 2010
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks guys. I will for sure have my mechanic take a look at it. It only does it after the truck is warm. After its started it runs great. I love my Powerstroke Ex
Reply With Quote Quick reply to this message
  #7  
Old 09-08-2011, 11:42 AM
Emergency Services

 

Join Date: Apr 2011
Location: Geraldton
Posts: 731
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by a2elvis View Post
Yep high pressure oil leak problem. Could be a bad pump on an 04, but not likely. High pressure oil leaks are the hardest thing to diagnose so without the proper scan tools and specialty tools it will be tough.
I was just thinking I would add a little update to the original thread...
Reply With Quote Quick reply to this message
  #8  
Old 10-21-2011, 04:47 PM
Premium Member
 

Join Date: Sep 2011
Location: Kellyville, OK
Posts: 142
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Update?

Any Luck? I had a similar problem and could help you troubleshoot if you wanted. I could at least point you in the right direction. I bought mine in march and it quit on me in 30 days, no start. So I got on here and read and read and read and then I got my voltohmeter out and started testing. rounded it down to STC fitting, dummy plugs or wide open IPR valve. ICP voltage showed no change from KOEO to cranking so I decided to replace the IPR valve and after cranking all the air out of the system it fired up and hasn't let me down yet. Since then I've started doing all the cheap easy mods. And because of my first "issue" I am more familiar with my truck then the average joe. Hell I can even talk shop with the local 6.0L genius shop owner and understand exactly what he is talking about now. LOL never owned a diesel before March. Love this truck...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:06 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors