Keeping the rear DVD working after new double din - Ford Powerstroke Diesel Forum
6.0L Ford Excursion Discussion This forum is for topics relating to the excursion only.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-06-2011, 01:16 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: Elk Point, Alberta
Posts: 673
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Keeping the rear DVD working after new double din

I am looking at getting a dvd/nav unit for the Ex and want to keep the rear dvd working properly (if I can). I was asking a local install shop for a quote and got $560 just to install as he says that the factory deck has to be relocated to the back to keep the rear dvd working. At that price I will do the job myself!

What have you guys done?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-07-2011, 07:43 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: Elk Point, Alberta
Posts: 673
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Nobody has a DVD/Nav unit in their Ex?
Reply With Quote Quick reply to this message
  #3  
Old 03-08-2011, 08:49 AM
Compression Ignition Addict
 

Join Date: Jan 2011
Location: LaGrange, GA
Posts: 335
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
I am doing this on my 03 7.3 Ex. I have the power working and am trying to hook into the speaker so the sound works. I will let you know if i get it to work. The current situation I have is the RSE working with the IR headphones. Hopefully I'll have it set up by the end of the week I will let you know.
Reply With Quote Quick reply to this message
  #4  
Old 03-08-2011, 09:57 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: Elk Point, Alberta
Posts: 673
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Thanks.
I am ordering my stuff and still gotta wait for the Ex to get back from getting studded. I am hoping a couple weeks at the most.
I am getting a Clarion NX500 and a couple amps for the aftermarket speakers, so I will have some work ahead of me finding places for the amps and possibly the old deck.
Reply With Quote Quick reply to this message
  #5  
Old 03-09-2011, 06:02 AM
Compression Ignition Addict
 

Join Date: Jan 2011
Location: LaGrange, GA
Posts: 335
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
well the way mine sits it works and I don't even own the factory head unit, bought mine without it. I will let you know how it goes and do a write up if I get the sound playing.
Reply With Quote Quick reply to this message
  #6  
Old 03-10-2011, 06:01 AM
Compression Ignition Addict
 

Join Date: Jan 2011
Location: LaGrange, GA
Posts: 335
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
I got it working last night with audio. I posted how I did it in the 7.3 Excursion section let me know if you have any questions about it.
Reply With Quote Quick reply to this message
  #7  
Old 03-13-2011, 07:21 AM
Compression Ignition Addict
 

Join Date: Aug 2010
Location: Finland
Posts: 451
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I change the orginal 2-din radio to Macrom 2-din dvd/sd/navi and what ever...
It plays radio too =)

I got a different problem. The orginal rear dvd player i got work by little mod to orginal wirring, but just after that i noticed that it wont play european discs!!!
only american format dvd:s and cant buy those here....

so i'm thinkin to simply take a rca cabels and take the audio and video from front to back.

just have to watch and listen what ever kids want to watch back seats....

if only i got the orginal rear speaker plugs to work.. then i could listen radio while driving and backseat could watch movie and listen it to headphones, but the damn rear headphone plugs are mute after the radio swap...

didt find the schematic for orginal audio wirring.

Last edited by juzatheman; 03-13-2011 at 12:17 PM.
Reply With Quote Quick reply to this message
  #8  
Old 03-13-2011, 03:10 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Location: Elk Point, Alberta
Posts: 673
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
juzatheman

There is a thread in the 7.3 Ex section that has some info and links that may help you out.
I am a couple weeks from getting my Ex back to tackle the job.
Reply With Quote Quick reply to this message
  #9  
Old 03-14-2011, 10:13 AM
Compression Ignition Addict
 

Join Date: Aug 2010
Location: Finland
Posts: 451
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Thanks for the info.

what i read, i think i got evrything like it sould be, but still no audio from the rear headphones plugs....

I never had test those headphone plugs with the old radio unit, so i don't know
has they ever worked...

don't know where to start looking to the problem.

Maby first thing is meassure that the wirring from the plugs to behind the radio is ok. or does the audio come staight from the back unit?
If so, then i have just take the video and audio from front player to back unit
and the headphones should work. (if it dos not make a loop from the front unit.)

i can with the macrom front headunit play dvd's to the rear output same time
when use the headunit to other things like radio, sd-card,dvd or reverse cam.

There even came two different remotecontrols to make it easyer to use.

just first need to learn how operate the whole package =)
Reply With Quote Quick reply to this message
  #10  
Old 04-03-2011, 07:59 PM
First 6.7 PS Destroyer

 

Join Date: Aug 2009
Location: Somerset, Ky
Posts: 1,728
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Have to relocate the factory HU to the rear?? Run from that place. You can buy a wiring harness to make it all work. I have a thread around here somewhere on doing it.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:28 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors