Surging when at red light with brake pedal pushed?? - Ford Powerstroke Diesel Forum
6.0L Ford Excursion Discussion This forum is for topics relating to the excursion only.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-10-2010, 10:21 AM
Powerstroke.org Rookie
 

Join Date: Aug 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Surging when at red light with brake pedal pushed??

Has anyone had this problem ??/ When you are stopped at a light with truck still in drive , the truck will give like 1-3 little surges !!! And then when you are driving around and cruise is on you can feel the truck surging again !!! Feels like when you are pushing accelerator quickly and then backing off !!!

I am wondering if there is something wrong in the computer ?? Or would it be the throttle position sesnsor in these trucks ??? Any help would be greatly appreciated !!!! Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-10-2010, 11:37 AM
Compression Ignition Addict
 

Join Date: Jul 2009
Location: Great Falls Montana
Posts: 312
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i have the same problem currently. theres TONS of things that can cause it and so far. i have been unable to get to a scan tool when it is acting up. mine goes away if i rev it in neutral. if you figure it out. let me know. im thinking ICP tho
Reply With Quote Quick reply to this message
  #3  
Old 08-10-2010, 11:57 AM
Powerstroke.org Rookie
 

Join Date: Aug 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Wojo View Post
i have the same problem currently. theres TONS of things that can cause it and so far. i have been unable to get to a scan tool when it is acting up. mine goes away if i rev it in neutral. if you figure it out. let me know. im thinking ICP tho
ICP That is interesting !!! A Mechanic I know thiks it might be a Throotle Position sensor ??? Do you have any Codes coming up / Check engine light on ?? Because they told me scan tool only works when Check engine light comes on ??? I will definitely keep you posted !!! Together we should be able to figure it out !!!
Reply With Quote Quick reply to this message
  #4  
Old 08-10-2010, 05:40 PM
Compression Ignition Addict
 

Join Date: Jul 2009
Location: Great Falls Montana
Posts: 312
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
nope no codes. an icp sensor will cause an intermittan irratic idle.
Reply With Quote Quick reply to this message
  #5  
Old 08-10-2010, 08:08 PM
Powerstroke.org Rookie
 

Join Date: Aug 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Wojo View Post
nope no codes. an icp sensor will cause an intermittan irratic idle.
But thats the thing it idles great !!! But when you are stopped it feels like the truck wants to surge ahead !! And then it stops and idles great !!!
Really Weird!!
Reply With Quote Quick reply to this message
  #6  
Old 08-10-2010, 09:21 PM
Compression Ignition Addict
 

Join Date: Jul 2009
Location: Great Falls Montana
Posts: 312
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yepp. same here. ive had the truck to the shop plenty of times. nobody can figure it out when its NOT doing it. it only does it when it wants. and so far. ive been failing
Reply With Quote Quick reply to this message
  #7  
Old 08-12-2010, 08:57 AM
Powerstroke.org Rookie
 

Join Date: Jun 2010
Location: windsor,nc
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Had this same problem about a year ago. Drove truck like it about two week finally through a code. But not ICP cleared code. About a week later same thing. Called dealer I got truck from (Finish Line Ford, Statesville NC). Parts Guy Was very helpful said it was ICP sencer. Suggested replacing it and wiring plug. Sent it to me only took over night. Just replaced Sencer not plug. No problem sence. Just my 2cents
Reply With Quote Quick reply to this message
  #8  
Old 08-12-2010, 07:39 PM
Compression Ignition Addict
 

Join Date: Jul 2009
Location: Great Falls Montana
Posts: 312
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
same thing here. truck keep throwing random codes. like Crank Sensor and map sensor. replaced bothe and no difference. i think i may go ahead and replace my ICP sensor (i have an 03 so its a *****) and HOPE thats the problem
Reply With Quote Quick reply to this message
  #9  
Old 08-12-2010, 07:48 PM
Compression Ignition Addict
 

Join Date: Dec 2006
Location: west jordan,utah
Posts: 331
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
almost certain it's icp sensor that's whay mine did it will get worse,replace the pigtail for the wireing harness also
Reply With Quote Quick reply to this message
  #10  
Old 11-30-2010, 08:05 AM
Powerstroke.org Rookie
 

Join Date: Nov 2010
Location: Richardson
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by tonkatoy1 View Post
Has anyone had this problem ??/ When you are stopped at a light with truck still in drive , the truck will give like 1-3 little surges !!! And then when you are driving around and cruise is on you can feel the truck surging again !!! Feels like when you are pushing accelerator quickly and then backing off !!!

I am wondering if there is something wrong in the computer ?? Or would it be the throttle position sesnsor in these trucks ??? Any help would be greatly appreciated !!!! Thanks
At stop lights mine was doing exactly that. RPMs would surge. Then the darn truck would "jump" a bit. Not much just enought to scare you. I am no mechanic, so we took it into Ford. Was the ICP. It was leaking oil too , that caused a short in connectors.

Hope this helps. Wish I new how to fix these problems myself. Dealer's are pricey !
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:21 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors