Questions regarding troubleshooting - Ford Powerstroke Diesel Forum
6.0L Ford Excursion Discussion This forum is for topics relating to the excursion only.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-20-2009, 05:04 PM
Powerstroke.org Rookie
 

Join Date: Aug 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Questions regarding troubleshooting

I previously owned a 2004 Ford Excursion Limited but within one year, foolishly traded it in on another vehicle. I recently purchased a 2005 Ford Excursion Eddie Bauer with 335,000 km (208,000 miles) on it, but I have some questions.

The first one is, can someone provide me photographs of the rear barn doors and hatch, focusing on the seals? I know that some of the seals are missing and I purchased a couple, but I suspect a couple are still missing due to the amount of dust and dirt that rests on top of the barn doors. The one I am suspecting is missing the most is one that runs vertical on the inside of the passenger side door. I have the L-shaped one on the driver side door that runs across and down, but on the passenger side, I just have the one that runs across. The dealership ordered a vertical seal for me, but it did not fit - it had Christmas tree clips but there are no holes on my door for them. The dealership thought that it might be a case that the doors are from an older Excursion because Ford changed the seals. I do not know. (The vehicle had been vandalized according to Carfax and they also hit a deer. Most of the missing seals and lackluster body fit is due to one or both repair jobs. I've found glass under the carpet in the back, so I suspect the vandalism was mainly the windows being smashed out.) Also, is that supposed to be a tight seal at the bottom of the front and rear doors? It gets caked with dirt and mud in there, and I can actually get my finger between the body of the vehicle and the door, without touching the seal - and it's like this on all four front doors. It just seems pointless, so I'm suspecting they put the wrong seals in or something.

This of course brings me to the next thing. Door fit and finish. Like I said, whoever did the bodywork obviously did it at quitting time on Fridays because the barn doors are not lined up properly. The drivers side one has had the paint rubbed through to the fiberglass. The front drivers door, when opens, has actually rubbed through the window seal on the outside, scraping it out. (Paint is also missing on the door.) Is it difficult to realign these? Can I just loosen bolts, try to line things up, and then tighten? (I just realized that it will be even more fun, since I won't actually be able to tighten them when they're in the right position.)

Before I forget, regarding the seals, if someone has a picture of the ones at the front of the hood, I would appreciate those too. I know that one is also missing, leaving the engine covered in bug remains.

I ended up pulling the knuckles and doing the front ball joints, upper and lower, so it would pass inspection. That was quite the experience - serves me right trying to save some money! But they're good now. I did find rusty sludge in the axle tubes though - not a lot, but a little, and the axles themselves were crusted, but I sanded them down and oiled them, and cleaned out the tube. Should I be concerned about some of that sludge in there?

The backup system keeps turning off when I put it in reverse. I remember my old Excursion doing this, but it was under factory warranty. The warranty on this does not cover that. How do I go about accessing those sensors? Can I pop the plastic off the top of the rear bumper? And where is the control unit located, so I can check it out?

Does anyone know if it is possible to pick up just one of the plastic pieces that covers the "arms" on the factory running board? One is cracked and sort of hanging. No other damage though.

When idling, I can hear a metallic rattly sound, almost as if - pardon this horrible example - you had a washer on a bolt and just set it on something vibrating. (Come to think of it, that example could be scary, if it's something similar to that.) It might be some random thing, but I thought I would mention it in case someone goes, "Oh yeah, that's so-and-so part, it does that," or something else well-known.

Okay, I'm getting there... not too much left, bear with me.

I like to let the vehicle warm up for two minutes - it is the 6.0 L turbo diesel and I know that with new engines, etc. etc. but I remember growing up to always warm them up, and I've just stuck with it. Anyway, if I do have to go relatively quickly and do not give it as much time to warm up, I've noticed two issues:

The transmission seems really reluctant to shift unless it really warms up. If I do not let off the pedal for a half-second, I'm sure I could redline the engine and it still wouldn't shift. I do not remember this with my old Excursion. After the transmission warms up, it shifts great, smooth as glass. Is there something that might need replacing? Any service that I should look at doing?

The next thing is again, with the engine not warmed up as much, at highway speed (nearing 60 mph and faster) the vehicle begins to surge, so rapidly it's almost a shudder. If I let off the pedal, then it goes away, but if I try to speed up again, it does it again. After the engine warms up - just a minute or so at these speeds - this goes away and again, smooth as glass.

It's not a real issue to me, but it might be indicative of something else, but I need to crank the engine about one, maybe two seconds, before it starts. Today, it took about three seconds. Again, not a big deal to me, though it is a bit of a concern since it is warm out, and I'm worried about what it might be like in the winter.

So really, that's about it. It's a bit of a list, but I think that it is stuff that I can fix. I do have an extended warranty from an aftermarket company on powertrain, seals (engine, transmission, etc. - not doors - d'oh!), and electronics. I figured it was worth it given the mileage on the vehicle.

The vehicle only cost $14,500 USD and the extended warranty for two years was $1,500 USD, so all in all, not a horrible deal. And I do love the vehicle. The next thing I need to do is replace the fuel filters - I've got them here in the box, just need to get a 35 mm wrench and/or socket. I also need to get an oil change done, as the dealership said they didn't do one, and the sticker on the window had the recommended mileage for the next one to be 10,000 miles -ago-. So it's a priority for me.

Anyway, if anyone has any suggestions, or can offer those photographs, I would appreciate it. I might go take photographs myself and show you the seal situation, so you can see what I'm talking about.

Thanks tons!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:12 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors