Fuel pressure sending unit loose - Ford Powerstroke Diesel Forum
6.0L Exterior Discussion Body and Accessories Talk

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-13-2014, 07:50 PM Thread Starter
Compression Ignition Addict
Join Date: Feb 2012
Location: Canton, Ga
Posts: 703
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 12
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
Fuel pressure sending unit loose

I installed the fuel pressure sending unit, that came with my gauge, yesterday and it seemed really loose. I put in in the test port. I also wasn't comfortable with the o ring that came with it. I swapped the O ring for the one that came off the test port plug I removed as well as added some Teflon tape to the threads. I filled the housing back up, but I haven't fired the truck up yet. Has anyone else had this issue, how did you fix it?

2004 F-250 Crew Cab FX4
PMM coolant filter, PMM EGR delete, SCT X3 w/ MPD, Atlas 80 FICM tune, 4" TB exhaust, MTW Stage 1, quad gauge pillar pod w/ Glowshift Maxtow gauges, Edge CTS

Originally Posted by F450Harley View Post
I really believe these trucks have adaptive behaviors to your driving habits. Your truck reflects you.
If you think your truck might let you down…………..it WILL.
6literdiesel is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome