hood will not pop up - Ford Powerstroke Diesel Forum
6.0L Exterior Discussion Body and Accessories Talk

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 Old 03-13-2013, 08:22 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2013
Location: west michigan
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
hood will not pop up

I ahve 2006 F350 6.0, I just bought it and the problem im haveing is when I pull the hood release nothing happens. I have to have someone hold the release out while I go and lift the hood up then I can reach in flip the lever and open the hood. Is this beacuse i need new lift supports ? the hood stays up fine when i get it open but you need to people to open the hood.
ford719 is offline  
post #2 of 14 Old 03-13-2013, 08:22 AM
Compression Ignition Addict
 
2000-7.3L's Avatar
 
Join Date: Aug 2012
Posts: 4,167
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 16 Times in 16 Posts
Feedback Score: 10 reviews
Latch might be sticking! Its a ford thing LOL
2000-7.3L is offline  
post #3 of 14 Old 03-13-2013, 08:26 AM
Super Moderator


 
SuperCrutyPS's Avatar
 
Join Date: Jul 2008
Location: Orangevale, CA
Posts: 14,968
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 213 Post(s)
Thanks: 76
Thanked 455 Times in 439 Posts
Garage
Feedback Score: 0 reviews
Squirt some WD-40 or equivalent in there to see if it frees up the latch. Try the easy stuff first.


Owner | Operator: Darryl
My Truck: Ol' Guy Garage
Tow Toy: Pilgrim International 31RE3SLF5
United States Navy - IC2 - '76-'80
SuperCrutyPS is offline  
post #4 of 14 Old 03-13-2013, 08:35 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2013
Location: west michigan
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I will try that tonight thanks
ford719 is offline  
post #5 of 14 Old 03-13-2013, 08:36 AM
Compression Ignition Addict
 
2000-7.3L's Avatar
 
Join Date: Aug 2012
Posts: 4,167
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 16 Times in 16 Posts
Feedback Score: 10 reviews
wd-40 or PB Blaster
2000-7.3L is offline  
post #6 of 14 Old 03-13-2013, 09:00 AM
WWW.COMPIGNTECH.COM

 
Join Date: Oct 2011
Posts: 9,369
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 98
Thanked 103 Times in 82 Posts
Feedback Score: 10 reviews
It could also be out of alignment.

l BRYAN l


WWW. COMPIGNTECH .COM

Look us up on Facebook
COMPRESSION IGNITION TECHNOLOGIES

l 2005 l Ford F250 l FTX l
[A Few Odds-N-Ends]

Tuscany is offline  
post #7 of 14 Old 03-13-2013, 11:47 AM
Compression Ignition Addict
 
Join Date: Feb 2012
Location: sacramento
Posts: 2,097
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 1 reviews
if I pull mine it clicks but doesnt pop up I just have to lift it until it stops at the catch point then move the lever to get it to go all the way up

KCCO
Paul Devereux
2005 FX4 Lariat Dark Shadow Gray
AirRaid Filter, 6 inch Pro Comp Lift. 17 inch Mikey Thompsons with 35 inch Nittos, sinister coolant filter, MBRP 4" straight pipe, 6K HID, Zoodad, SCT with tunes from Vivian (Looney and Looney fuel) and Tony, dashboss with EGT and FP, 08' tail lights, blue spring, lowes CCV mod, 03' turbo

Soon... coolant flush.

DEVERO2 is offline  
post #8 of 14 Old 03-14-2013, 02:57 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2013
Location: west michigan
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by DEVERO2 View Post
if I pull mine it clicks but doesnt pop up I just have to lift it until it stops at the catch point then move the lever to get it to go all the way up
Thats what mine does, trided Wd-40 but the same problem, I see the rock auto has new lifts for 11 or 12 dollars so I may get a new set and see if that works. the hood gaps look ok and I cant see any thing on the latch where it looks like its rubbing where something is out whack
ford719 is offline  
post #9 of 14 Old 03-15-2013, 04:35 AM
Serving Our Country!
 
ctrow89's Avatar
 
Join Date: May 2009
Location: Jackson, MO
Posts: 265
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
I just replaced my lift supports 2-3 months ago because I was having the same issue. It didn't fix the problem on my truck completely. Sometimes it will, sometimes it doesn't pop up. It does however finish opening a lot faster and has a noticable difference, so it could be a combination of both. I haven't tried WD-40 yet because I've been gone.

2011 Ford F-250 CCSB Lariat
-Bone stock

**Picture to Come**
ctrow89 is offline  
post #10 of 14 Old 03-15-2013, 07:08 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2013
Location: west michigan
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
well i guess i will try lubeing up again and see if works this time
ford719 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome