Retro Solutions HID help - Ford Powerstroke Diesel Forum
6.0L Exterior Discussion Body and Accessories Talk

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-15-2012, 05:35 PM
Member
 

Join Date: Jul 2012
Location: Phoenix, AZ
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Retro Solutions HID help

I just installed the Retro Solutions HID Bixenon kit today in my 05 350 and for some reason only the hi's work. When I switch over to the low's on the dash panel, the lights turn off. I have searched this site and have been unable to find the answer.


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-15-2012, 05:41 PM
Member
 

Join Date: Jul 2012
Location: Phoenix, AZ
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Oh and this was my first HID kit and install so I didn't know if it's normal but the 4-5 pin plug that attached to the back of stock H13's, only one was used in the kit an there was not a connection for the other one in the kit. Didn't know if that is normal.


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
  #3  
Old 07-15-2012, 06:57 PM
Member
 

Join Date: Jun 2012
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Your kit came with a relay ?
Reply With Quote Quick reply to this message
  #4  
Old 07-15-2012, 07:19 PM
Member
 

Join Date: Jul 2012
Location: Phoenix, AZ
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Im pretty sure it did. Like I said, this is the first time I've even seen an hid kit system but on a previous post from another topic in this forum a rep from retro solutions mentioned that the h13 Bixenon kits come with a relay built in.


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
  #5  
Old 07-15-2012, 08:25 PM
Member
 

Join Date: Jun 2012
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
They shut be plug and play .
Reply With Quote Quick reply to this message
  #6  
Old 07-15-2012, 08:27 PM
Member
 

Join Date: Jun 2012
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I got a Honda civic hatchback . Also . And I put it .

Really easy .
Reply With Quote Quick reply to this message
  #7  
Old 07-15-2012, 08:28 PM
Member
 

Join Date: Jun 2012
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Did you check YouTube . ?
Reply With Quote Quick reply to this message
  #8  
Old 07-16-2012, 08:38 AM
Compression Ignition Addict
 

Join Date: Jun 2007
Posts: 288
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
give retro a call. they will help you fix the problem.
Reply With Quote Quick reply to this message
  #9  
Old 07-16-2012, 10:18 AM
Powerstroke.org Rookie
 

Join Date: Jul 2012
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
you might not have ordered the correct kit. I also have the 55w kit from retro solutions. Everything was plug and play for me.
Reply With Quote Quick reply to this message
  #10  
Old 07-16-2012, 10:22 AM
Serving Our Country!


 

Join Date: Oct 2007
Location: San Diego, CA
Posts: 4,491
Thanks: 77
Thanked 38 Times in 27 Posts
Feedback Score: 0 reviews
I would give retro a call, but it sounds like a grounding issue. Did you make sure the ground was bare metal and use electrical grease on the connection?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:32 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors