Random power loss - Ford Powerstroke Diesel Forum
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 07-23-2014, 08:41 AM Thread Starter
Member
 
Join Date: Jan 2014
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Random power loss

So heres the deal, I'll be driving down the road and the battery light will come on and then the dash electricity will shut off. Doesn't effect the drivability but it will shut off for about a second and then it resets and comes back on. Not a big deal but has anybody else had this problem?

The only electronic mods i have are bed lights wired into the 4th aux fuze behind the glove box and an sct livewire thats in the obd2 and cig lighter under the radio.
PowertotheStoke is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-04-2014, 09:59 PM
Powerstroke.org Fanatic
 
Join Date: Apr 2013
Posts: 92
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Seems like this problem is happening to a few people, myself included. In another thread, a person said to check the fuses. Have you done that?

I haven't looked into mine yet.
aruba is offline  
post #3 of 3 Old 08-10-2014, 08:26 AM Thread Starter
Member
 
Join Date: Jan 2014
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
I have not checked the fuses. I'd assume that if it were a fuse that it wouldn't work sometimes or why only the brake light would come on right before the loss.

I'll check the fuses and see if anything is loose.

06 XL ext-cab shortbed

-Headstuds
-EGR cooler delete
-Sinister Coolant Filter Kit w/ Napa 4070 filter
-4" MBRP straightpipe
-Wicked Wheel 2
-K&N intake
-SCT Livewire w/ SRL+ tune
-JMS egt probe
-blue spring mod
-2.5" leveling kit
-33" BFG A/T's

Yes, I did mean to make my username PowertotheStroke but I made a typo
PowertotheStoke is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome